View Issue Details

IDProjectCategoryView StatusLast Update
0005616GNUnetdocumentationpublic2019-04-03 16:55
Reporterng0Assigned Tong0 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.11.1Fixed in Version0.11.1 
Summary0005616: build system integration for doc folder does not work as intended
Descriptionexpectation:
  * --disable-documentation does not build doc/handbook
  * --disable-documentation does install doc/man/man1 + doc/man/man5
  * if --disable-documentation and --enable-texi2mdoc-generation are both true,
     texi2mdoc rule (inside doc/handbook and doc/tutorial) builds an output of
     the texi files and puts them in doc/man/man7/

reality:
  * --disable-documentation implies not installing doc/man/*
  * effects on texi2mdoc: does not build at all if --disable-documentation
     is passed to configure (confirmed.)

this was observed doing tests with my local branch of pkgsrc-wip package for gnunet
TagsNo tags attached.

Activities

ng0

2019-02-28 11:54

developer   ~0014101

This can be resolved by untangling the new structure in doc and the makefiles in there, as well as their include/exclude statements for conditional variables.

ng0

2019-04-01 14:46

developer   ~0014246

* --disable-documentation implies not installing doc/man/*
  * effects on texi2mdoc: does not build at all if --disable-documentation
     is passed to configure (confirmed.)


I have looked at this again. It works as intended. The problem here is that I need to be more specific.
If someone does not want to build documentation, do I want this statement to mean "okay, I do not build and install any category of documentation at all" or do I want it to mean "okay, I do not build and install the texinfo kind documentation category but install the rest"?
Before moving to texinfo we have (although in private) discussed the importance of documentation available offline. --enable-documentation is the default. distributors can override this.
I think the best choice would be a more fine grained "--enable-man" as another option which then only gives you the manpages and optionally the generated mdoc pages.

ng0

2019-04-01 15:06

developer   ~0014247

I'm testing my --enable-include-manpages now.

ng0

2019-04-01 21:57

developer   ~0014256

texi2mdoc now generates output again after a long bikeshed painting session.
previous commits fixed the other items of this ticket.

Issue History

Date Modified Username Field Change
2019-02-28 11:17 ng0 New Issue
2019-02-28 11:42 ng0 Target Version => 0.11.1
2019-02-28 11:47 Christian Grothoff Status new => acknowledged
2019-02-28 11:53 ng0 Description Updated View Revisions
2019-02-28 11:54 ng0 Note Added: 0014101
2019-02-28 12:02 ng0 Description Updated View Revisions
2019-02-28 12:08 ng0 Description Updated View Revisions
2019-04-01 14:18 ng0 Assigned To => ng0
2019-04-01 14:18 ng0 Status acknowledged => assigned
2019-04-01 14:18 ng0 Status assigned => acknowledged
2019-04-01 14:46 ng0 Note Added: 0014246
2019-04-01 15:06 ng0 Note Added: 0014247
2019-04-01 21:57 ng0 Status acknowledged => resolved
2019-04-01 21:57 ng0 Resolution open => fixed
2019-04-01 21:57 ng0 Fixed in Version => 0.11.1
2019-04-01 21:57 ng0 Note Added: 0014256
2019-04-03 16:55 Christian Grothoff Status resolved => closed