View Issue Details

IDProjectCategoryView StatusLast Update
0005607GNUnetbuild processpublic2019-02-28 11:17
Reporterng0Assigned Tong0 
PrioritylowSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.11.0 
Summary0005607: portability for make
DescriptionWe only have 1 or 2 Gnu make specific features used in our makefiles

$(shell which env)

is one of them.

Find a better way to get the absolute location of something.

This is not RC, not high priority and rather a feature to make the make less opinionated on implementation
(portability!).
Don't close this because gnu make could run everywhere. NetBSD make runs through the entire build
but just fails to work on the 2 rules (simply ignores them).
pkgsrc targets multiple platforms, operating systems etc and they could use whatever is expected for the
platform or a set make (USE_TOOLS+= gmake).
TagsNo tags attached.

Activities

ng0

2019-02-24 14:51

developer   ~0014009

Actually we have more gnu make in there, but which env is the only one netbsd make trips on.

ng0

2019-02-26 16:48

developer   ~0014075

Resolved by using more portable code and/or removing the code altogether.

Issue History

Date Modified Username Field Change
2019-02-24 14:47 ng0 New Issue
2019-02-24 14:47 ng0 Status new => assigned
2019-02-24 14:47 ng0 Assigned To => ng0
2019-02-24 14:51 ng0 Note Added: 0014009
2019-02-26 16:48 ng0 Status assigned => resolved
2019-02-26 16:48 ng0 Resolution open => fixed
2019-02-26 16:48 ng0 Fixed in Version => 0.11.0
2019-02-26 16:48 ng0 Note Added: 0014075
2019-02-28 11:17 Christian Grothoff Status resolved => closed