View Issue Details

IDProjectCategoryView StatusLast Update
0005606GNUnetbuild processpublic2019-02-28 11:18
ReporterschanzenAssigned Todangole 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSmacOSOS Version
Product VersionSVN HEAD 
Target Version0.11.0Fixed in Version0.11.0 
Summary0005606: GNUnet ftbfs
Descriptionmake fails:

  CC tun.lo
  CC speedup.lo
  CC proc_compat.lo
  CCLD libgnunetutil.la
ld: library not found for -latomic
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[3]: *** [libgnunetutil.la] Error 1
make[2]: *** [all-recursive] Error 1
Steps To ReproduceBuild on macOS
TagsNo tags attached.

Activities

schanzen

2019-02-24 11:14

developer   ~0013998

Temporary fix in ca5e6a9b9..b0da4b2b9, but maybe we should limit this flag to architecture whoch actually need it instead of excluding those that don't?

schanzen

2019-02-24 16:31

developer   ~0014020

Changed target version, we should fix this for the next version. The current fix works for me (TM)

Christian Grothoff

2019-02-25 22:05

manager   ~0014037

So is this fixed for everyone?

Christian Grothoff

2019-02-28 11:18

manager   ~0014095

Presumably fixed.

Issue History

Date Modified Username Field Change
2019-02-24 10:44 schanzen New Issue
2019-02-24 10:44 schanzen Status new => assigned
2019-02-24 10:44 schanzen Assigned To => dangole
2019-02-24 11:06 schanzen OS => macOS
2019-02-24 11:06 schanzen Steps to Reproduce Updated View Revisions
2019-02-24 11:14 schanzen Status assigned => feedback
2019-02-24 11:14 schanzen Note Added: 0013998
2019-02-24 16:31 schanzen Priority urgent => normal
2019-02-24 16:31 schanzen Target Version 0.11.0 => 0.11.1
2019-02-24 16:31 schanzen Note Added: 0014020
2019-02-24 16:31 schanzen Status feedback => assigned
2019-02-25 22:05 Christian Grothoff Note Added: 0014037
2019-02-28 11:18 Christian Grothoff Status assigned => closed
2019-02-28 11:18 Christian Grothoff Resolution open => fixed
2019-02-28 11:18 Christian Grothoff Fixed in Version => 0.11.0
2019-02-28 11:18 Christian Grothoff Note Added: 0014095
2019-02-28 11:18 Christian Grothoff Target Version 0.11.1 => 0.11.0