View Issue Details

IDProjectCategoryView StatusLast Update
0005605GNUnetbuild processpublic2019-02-28 11:17
Reporternikita Assigned Tonikita  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Platformpkgsrc amd64OSNetBSDOS Versioncurrent
Fixed in Version0.11.0 
Summary0005605: pkgsrc package build from gnunet git HEAD throws errors related to NSS_
DescriptionI have a vague memory that we talked about this before.

I'm currently packaging gnunet for pkgsrc-wip (unpushed local state), and it fails with errors
related to NSS_

See the appended log.
TagsNo tags attached.

Activities

nikita

2019-02-24 00:38

developer  

gnunet_pkgsrc_build (306,228 bytes)

Christian Grothoff

2019-02-24 13:33

manager   ~0014005

Does netbsd use GNU libc? If not, I suspect they simply don't have the NSS logic required for what this code does. I propose we disable nss building on BSD.

nikita

2019-02-24 13:44

developer   ~0014006

There's a compatibility mode where glibc can be used, but I'd prefer native libc.
I have compat mode on my system with a glibc installed, but the pkgsrc does
not expose this.

What are the implications of disabling this?

nikita

2019-02-24 13:45

developer   ~0014007

Expanding on this, pkgsrc can define packages using glibc, but I only want this if really absolutely necessary.

nikita

2019-02-24 14:12

developer   ~0014008

Further question: is there a way we can solve this without relying on glibc or by handling this different for other libcs?

Christian Grothoff

2019-02-24 15:16

manager   ~0014012

One mechanism of integrating GNS with legacy applications via NSS is not available if this is disabled.
But applications that don't use the glibc for NS resolution won't work anyway with this, so little is lost on BSD systems.
GNS via direct use or via the HTTP or DNS proxies is unaffected.

Christian Grothoff

2019-02-24 15:17

manager   ~0014013

And no, this cannot be done without GNU libc, as we need OTHER applications to use GNU libc for this to be useful!

nikita

2019-02-24 15:20

developer   ~0014014

I see. Okay

nikita

2019-02-24 15:27

developer   ~0014016

Last edited: 2019-02-24 15:27

View 2 revisions

I'd say this is resolved then? Maybe having an overwrite (--with/--without) makes sense, because
I did not get this error in my checkout. Only in pkgsrc environment.

My user environment has emulators/suse131_compat and emulators/suse131_base for another
application which requires some functions.

Christian Grothoff

2019-02-24 15:30

manager   ~0014017

Well, does it build on BSD now (without NSS)? If so, I think we can call this resolved.

nikita

2019-02-26 16:06

developer   ~0014066

yes

nikita

2019-02-26 16:07

developer   ~0014067

builds on NetBSD

Issue History

Date Modified Username Field Change
2019-02-24 00:38 nikita New Issue
2019-02-24 00:38 nikita File Added: gnunet_pkgsrc_build
2019-02-24 13:33 Christian Grothoff Note Added: 0014005
2019-02-24 13:44 nikita Note Added: 0014006
2019-02-24 13:45 nikita Note Added: 0014007
2019-02-24 14:12 nikita Note Added: 0014008
2019-02-24 15:16 Christian Grothoff Note Added: 0014012
2019-02-24 15:17 Christian Grothoff Note Added: 0014013
2019-02-24 15:20 nikita Note Added: 0014014
2019-02-24 15:27 nikita Note Added: 0014016
2019-02-24 15:27 nikita Note Edited: 0014016 View Revisions
2019-02-24 15:30 Christian Grothoff Note Added: 0014017
2019-02-24 15:30 Christian Grothoff Assigned To => Christian Grothoff
2019-02-24 15:30 Christian Grothoff Status new => feedback
2019-02-26 16:03 Christian Grothoff Assigned To Christian Grothoff => nikita
2019-02-26 16:06 nikita Note Added: 0014066
2019-02-26 16:07 nikita Status feedback => resolved
2019-02-26 16:07 nikita Resolution open => fixed
2019-02-26 16:07 nikita Fixed in Version => 0.11.0
2019-02-26 16:07 nikita Note Added: 0014067
2019-02-28 11:17 Christian Grothoff Status resolved => closed