View Issue Details

IDProjectCategoryView StatusLast Update
0005554GNUnetbuild processpublic2019-02-09 23:01
Reporterng0Assigned ToChristian Grothoff 
PrioritynormalSeverityblockReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformamd64OSNetBSDOS VersionCURRENT
Product VersionSVN HEAD 
Target Version0.11.0Fixed in Version0.11.0 
Summary0005554: conflicting types for hmac
DescriptionWhile building gnunet like this:
./boostrap
LDFLAGS=-L/usr/pkg/lib ./configure
gmake

I currently am stuck here:


gnunet-communicator-tcp.c:641:1: error: conflicting types for 'hmac'
 hmac (struct GNUNET_HashCode *hmac_secret,
 ^~~~
In file included from ../../src/include/platform.h:110:0,
                 from gnunet-communicator-tcp.c:36:
/usr/include/stdlib.h:305:10: note: previous declaration of 'hmac' was here
 ssize_t hmac(const char *, const void *, size_t, const void *, size_t, void *,
          ^~~~
gmake[3]: *** [Makefile:4186: gnunet-communicator-tcp.o] Error 1
gmake[3]: Leaving directory '/home/ng0/src/gnunet/gnunet/src/transport'
gmake[2]: *** [Makefile:554: all-recursive] Error 1
gmake[2]: Leaving directory '/home/ng0/src/gnunet/gnunet/src'
gmake[1]: *** [Makefile:608: all-recursive] Error 1
gmake[1]: Leaving directory '/home/ng0/src/gnunet/gnunet'
gmake: *** [Makefile:498: all] Error 2
TagsNo tags attached.

Activities

ng0

2019-02-09 17:28

developer   ~0013632

Note that my way of building might still be off, these are first attempts to document what's needed.

ng0

2019-02-09 18:01

developer  

config.log (486,965 bytes)

ng0

2019-02-09 22:52

developer   ~0013634

someone in #pkgsrc says that NetBSD provides a hmac in a too visible header which was complained about too late.

my understanding after a short chat is that every time hmac appears, they patch it to something else. It doesn't occur too often, but it causes problems.

My proposal, since this part of gnunet is very recent, is to call it 'gnunet_hmac'.

ng0

2019-02-09 22:56

developer   ~0013635

Rename to fix is the recommended solution here, because otherwise I have to patch-to-rename-to-fix in the pkgsrc package for gnunet I'm working on refreshing.
probably no other OS is bothered by this fix.

Christian Grothoff

2019-02-09 22:59

manager   ~0013636

Indeed. Will do.

Christian Grothoff

2019-02-09 23:00

manager   ~0013637

Fixed in 25c5d5e5a..a9a0d8fde

Issue History

Date Modified Username Field Change
2019-02-09 17:26 ng0 New Issue
2019-02-09 17:28 ng0 Note Added: 0013632
2019-02-09 18:01 ng0 File Added: config.log
2019-02-09 22:52 ng0 Note Added: 0013634
2019-02-09 22:52 ng0 Assigned To => Christian Grothoff
2019-02-09 22:52 ng0 Status new => feedback
2019-02-09 22:56 ng0 Note Added: 0013635
2019-02-09 22:56 ng0 Status feedback => assigned
2019-02-09 22:59 Christian Grothoff Note Added: 0013636
2019-02-09 23:00 Christian Grothoff Note Added: 0013637
2019-02-09 23:00 Christian Grothoff Status assigned => resolved
2019-02-09 23:00 Christian Grothoff Resolution open => fixed
2019-02-09 23:00 Christian Grothoff Fixed in Version => 0.11.0
2019-02-09 23:01 Christian Grothoff Product Version => SVN HEAD
2019-02-09 23:01 Christian Grothoff Target Version => 0.11.0