View Issue Details

IDProjectCategoryView StatusLast Update
0005548GNUnettransport servicepublic2020-01-13 17:40
ReporterChristian GrothoffAssigned Toschanzen 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.12.2Fixed in Version0.12.2 
Summary0005548: communicator rekey test plan
DescriptionFor this test, the communicator logic must be changed to introduce an option for the rekey frequency. Then, the test case should use a configuration setting the rekey frequency to say 100ms. Finally, as 0005547 messages should be transmitted for 2 seconds, again measuring communicator performance.

Note that the actual C code of the test should be *identical* to that of 0005547, only support for a retransmission frequency option must be added (currently a #define) and set to a small value in the respective configuration.
TagsNo tags attached.

Relationships

child of 0005710 confirmed TNG meta issue 

Activities

schanzen

2019-12-31 05:22

manager   ~0015229

Rekey tests added in c594ee5be..658ba3f2b.
UDP does not work, but that is due to UDP communicator issues => Out of scope if this issue.

schanzen

2020-01-13 17:40

manager   ~0015266

0.12.2 released

Issue History

Date Modified Username Field Change
2019-02-08 18:59 Christian Grothoff New Issue
2019-02-08 18:59 Christian Grothoff Status new => assigned
2019-02-08 18:59 Christian Grothoff Assigned To => ch3
2019-02-12 09:22 Christian Grothoff Target Version => 0.12.0
2019-05-02 14:40 Christian Grothoff Relationship added child of 0005710
2019-05-03 18:54 Christian Grothoff Assigned To ch3 =>
2019-05-03 18:54 Christian Grothoff Status assigned => confirmed
2019-11-16 18:41 Christian Grothoff Target Version 0.12.0 => 0.13.0
2019-12-31 05:22 schanzen Assigned To => schanzen
2019-12-31 05:22 schanzen Status confirmed => resolved
2019-12-31 05:22 schanzen Resolution open => fixed
2019-12-31 05:22 schanzen Note Added: 0015229
2019-12-31 05:22 schanzen Fixed in Version => 0.12.2
2020-01-01 04:16 schanzen Target Version 0.13.0 => 0.12.2
2020-01-13 17:40 schanzen Note Added: 0015266
2020-01-13 17:40 schanzen Status resolved => closed