View Issue Details

IDProjectCategoryView StatusLast Update
0005541GNUnetotherpublic2019-08-17 18:13
ReporterdvnAssigned To 
PriorityhighSeverityblockReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0005541: Add KVM and libvirt to firefly.gnunet.org
DescriptionFor the purpose of using arbitrary job runners - for CI and other purposes - it is preferred to have some form of environment isolation, and the ability to run various kernels. KVM and libvirt are what I would recommend and prefer, due to availability of packages, documentation, and community support.

The server `firefly.gnunet.org`, is running GuixSD. We need to require some new services in its server config.

I will attach a full example config of a similar setup I've used in the past.

I believe the relevant lines are just these:

 9 (use-service-modules networking mcron desktop virtualization)
...
 52 (supplementary-groups '("wheel" "netdev"
 53 "audio" "video" "kvm" "libvirt"))
...
 71 (service libvirt-service-type
 72 (libvirt-configuration
 73 (unix-sock-group "libvirt")))
 74 (service virtlog-service-type
 75 (virtlog-configuration
 76 (max-clients 1000)))
TagsNo tags attached.

Activities

dvn

2019-02-04 20:22

developer  

firefly-kvm-config-example.scm (2,726 bytes)

ng0

2019-02-26 13:33

developer   ~0014059

Thanks, should be done today.

I'm only stuck with firefly building almost everything from source because the commit is too old (0.16.0 release now).

ng0

2019-02-26 14:50

developer   ~0014061

Done. Can you confirm functionality?

ng0

2019-02-26 16:12

developer   ~0014068

Note, ch3 is running tests on firefly right now, so if it's still occupied, wait with anything resource intensive (or wait in general).

schanzen

2019-08-08 19:46

manager   ~0014778

Is this still an issue?

ng0

2019-08-17 11:30

developer   ~0014784

Somehow I got an 'requested feedback' Email about this.
Please ask ch3 yourself, I haven't been active on the servers in the last months.

ng0

2019-08-17 11:30

developer   ~0014785

Though we no longer use GuixSD, so maybe this is resolved? (others will know more)

dvn

2019-08-17 18:11

developer   ~0014791

This issue is resolved. KVM and libvirt are installed on firefly.

Issue History

Date Modified Username Field Change
2019-02-04 20:22 dvn New Issue
2019-02-04 20:22 dvn Status new => assigned
2019-02-04 20:22 dvn Assigned To => ng0
2019-02-04 20:22 dvn File Added: firefly-kvm-config-example.scm
2019-02-26 13:28 ng0 Status assigned => acknowledged
2019-02-26 13:33 ng0 Note Added: 0014059
2019-02-26 14:50 ng0 Note Added: 0014061
2019-02-26 14:50 ng0 Assigned To ng0 => dvn
2019-02-26 14:50 ng0 Status acknowledged => feedback
2019-02-26 16:12 ng0 Note Added: 0014068
2019-08-08 19:46 schanzen Status feedback => acknowledged
2019-08-08 19:46 schanzen Status acknowledged => feedback
2019-08-08 19:46 schanzen Note Added: 0014778
2019-08-17 11:30 ng0 Note Added: 0014784
2019-08-17 11:30 ng0 Note Added: 0014785
2019-08-17 12:06 schanzen Assigned To dvn => ch3
2019-08-17 18:11 dvn Note Added: 0014791
2019-08-17 18:11 dvn Status feedback => assigned
2019-08-17 18:13 dvn Assigned To ch3 =>
2019-08-17 18:13 dvn Status assigned => resolved
2019-08-17 18:13 dvn Resolution open => fixed