View Issue Details

IDProjectCategoryView StatusLast Update
0005471GNUnetidentity servicepublic2019-02-28 11:17
Reporterng0Assigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
PlatformOSGentooOS Version
Product VersionSVN HEAD 
Target Version0.11.0Fixed in Version0.11.0 
Summary0005471: in system-user context, normal user can not create identity
DescriptionHere's the last couple of lines of a strace of gnunet-idenity -C myself:


connect(6, {sa_family=AF_UNIX, sun_path="/tmp/gnunet-ng0-runtime//gnunet-service-identity.sock"}, 110) = -1 ENOENT (No such file or directory)
close(6) = 0
select(5, [4], [], NULL, {tv_sec=65, tv_usec=535997}) = 0 (Timeout)
socket(AF_UNIX, SOCK_STREAM, 0) = 6
fcntl(6, F_GETFD) = 0
fcntl(6, F_SETFD, FD_CLOEXEC) = 0
fcntl(6, F_GETFL) = 0x2 (flags O_RDWR)
fcntl(6, F_SETFL, O_RDWR|O_NONBLOCK) = 0
connect(6, {sa_family=AF_UNIX, sun_path="/tmp/gnunet-ng0-runtime//gnunet-service-identity.sock"}, 110) = -1 ENOENT (No such file or directory)
close(6) = 0
select(5, [4], [], NULL, {tv_sec=131, tv_usec=71997}) = 0 (Timeout)
socket(AF_UNIX, SOCK_STREAM, 0) = 6
fcntl(6, F_GETFD) = 0
fcntl(6, F_SETFD, FD_CLOEXEC) = 0
fcntl(6, F_GETFL) = 0x2 (flags O_RDWR)
fcntl(6, F_SETFL, O_RDWR|O_NONBLOCK) = 0
connect(6, {sa_family=AF_UNIX, sun_path="/tmp/gnunet-ng0-runtime//gnunet-service-identity.sock"}, 110) = -1 ENOENT (No such file or directory)
close(6) = 0
select(5, [4], [], NULL, {tv_sec=262, tv_usec=143998}
^C) = ? ERESTARTNOHAND (To be restarted if no handler)
strace: Process 15961 detached
Additional Informationgnunet is on the latest checkout, gnunet-search and similar operations work.
TagsNo tags attached.

Activities

ng0

2018-11-04 17:47

developer   ~0013320

Forgot to add: ls -al /tmp/

-rw------- 1 gnunet gnunet 262144 Nov 4 16:42 gnunet-datacachebloomGFfU0w
drwxr-xr-x 2 gnunet gnunet 4096 Nov 4 15:13 gnunet-gnunet-runtime
drwxr-xr-x 2 gnunet gnunet 4096 Nov 4 15:13 gnunet-system-runtime


ls -al /tmp/gnunet-system-runtime/
total 8
drwxr-xr-x 2 gnunet gnunet 4096 Nov 4 15:13 .
drwxrwxrwt 7 root root 4096 Nov 4 16:16 ..
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-ats.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-cadet.sock
srwx------ 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-consensus.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-core.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-datastore.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-dht.sock
srwx------ 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-dns.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-fs.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-namecache.sock
srwx------ 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-nat-auto.sock
srwx------ 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-nat.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-nse.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-peerinfo.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-peerstore.sock
srwxrwxrwx 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-regex.sock
srwxrwxrwx 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-resolver.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-revocation.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-scalarproduct-alice.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-scalarproduct-bob.sock
srwx------ 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-set.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-statistics.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-transport.sock
srwxrwx--- 1 gnunet gnunet 0 Nov 4 15:13 gnunet-service-vpn.sock

Christian Grothoff

2018-11-09 22:44

manager   ~0013325

Well, identities are not something to be used by the 'system-user', they are a concept for the 'end-user'. Why would you expect this to work in the first place?

ng0

2018-11-10 16:04

developer   ~0013326

I run gnunet as a system use, but interact with identity as a normal user.

Christian Grothoff

2019-02-13 23:58

manager   ~0013732

The identity service is supposed to be launched once *per* user using it. That's why we have the notion of a USER_SERVICE (yes/no). Basically, in a multi-user system, each user will have the private keys of their egos in their $HOME under their gnunet-service-identity. gnunet-search works as "gnunet" because it doesn't care about per-user services. (FS is not marked as USER_SERVICE; indeed it ultimately should be, but that'll require a design change which is still not implemented). So to summarize, this reads like expected behavior.

See also: https://docs.gnunet.org/#The-Multi_002dUser-Setup

Issue History

Date Modified Username Field Change
2018-11-04 17:45 ng0 New Issue
2018-11-04 17:47 ng0 Note Added: 0013320
2018-11-04 17:54 ng0 OS => Gentoo
2018-11-09 22:44 Christian Grothoff Note Added: 0013325
2018-11-09 22:44 Christian Grothoff Assigned To => ng0
2018-11-09 22:44 Christian Grothoff Status new => feedback
2018-11-10 16:04 ng0 Note Added: 0013326
2018-11-10 16:05 ng0 Assigned To ng0 => Christian Grothoff
2019-02-13 23:58 Christian Grothoff Note Added: 0013732
2019-02-13 23:58 Christian Grothoff Status feedback => resolved
2019-02-13 23:58 Christian Grothoff Resolution open => no change required
2019-02-13 23:58 Christian Grothoff Fixed in Version => 0.11.0
2019-02-13 23:58 Christian Grothoff Target Version => 0.11.0
2019-02-28 11:17 Christian Grothoff Status resolved => closed