View Issue Details

IDProjectCategoryView StatusLast Update
0005467GNUnetrps servicepublic2019-02-28 11:17
Reporterch3Assigned ToChristian Grothoff 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0Fixed in Version0.11.0 
Summary0005467: Most rps testcases crash since hashmap change
DescriptionStack traces look like this, running the profiler with valgrind didn't yield any additional information:

==29683== Memcheck, a memory error detector
==29683== Copyright (C) 2002-2017, and GNU GPL'd, by Julian Seward et al.
==29683== Using Valgrind-3.13.0 and LibVEX; rerun with -h for copyright info
==29683== Command: .libs/gnunet-rps-profiler -c test_rps.conf -n 128 -d 30m -r 10000 -l gnunet_rps_profiler.log
==29683== Parent PID: 93566
==29683==
==29683==
==29683== Process terminating with default action of signal 6 (SIGABRT): dumping core
==29683== at 0x77F1A50: raise (in /gnu/store/l4lr0f5cjd0nbsaaf8b5dmcw1a1yypr3-glibc-2.27/lib/libc-2.27.so)
==29683== by 0x77F2C30: abort (in /gnu/store/l4lr0f5cjd0nbsaaf8b5dmcw1a1yypr3-glibc-2.27/lib/libc-2.27.so)
==29683== by 0x5260A35: GNUNET_abort_ (common_logging.c:282)
==29683== by 0x5273858: GNUNET_CONTAINER_multihashmap32_get_multiple (container_multihashmap32.c:558)
==29683== by 0x54CDCA4: find_opc.isra.1 (testbed_api.c:288)
==29683== by 0x54CE52D: handle_peer_create_success (testbed_api.c:563)
==29683== by 0x5262DDD: recv_message (client.c:334)
==29683== by 0x528BB02: GNUNET_MST_from_buffer (mst.c:232)
==29683== by 0x5263D4A: receive_ready (client.c:421)
==29683== by 0x52A00AE: GNUNET_SCHEDULER_do_work (scheduler.c:2113)
==29683== by 0x52A0F19: select_loop (scheduler.c:2410)
==29683== by 0x52A0F19: GNUNET_SCHEDULER_run (scheduler.c:725)
==29683== by 0x52978C7: GNUNET_PROGRAM_run2 (program.c:341)
==29683==
==29683== HEAP SUMMARY:
==29683== in use at exit: 383,526 bytes in 9,692 blocks
==29683== total heap usage: 71,926 allocs, 62,234 frees, 13,708,546 bytes allocated
==29683==
==29683== LEAK SUMMARY:
==29683== definitely lost: 0 bytes in 0 blocks
==29683== indirectly lost: 0 bytes in 0 blocks
==29683== possibly lost: 0 bytes in 0 blocks
==29683== still reachable: 383,526 bytes in 9,692 blocks
==29683== suppressed: 0 bytes in 0 blocks
==29683== Rerun with --leak-check=full to see details of leaked memory
==29683==
==29683== For counts of detected and suppressed errors, rerun with: -v
==29683== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 0 from 0)
Steps To ReproduceRun profiler or rps testcases (in `src/rps/`: `make check`).
TagsNo tags attached.

Activities

ch3

2018-11-02 14:28

developer   ~0013309

Neither core nor cadet testcases seem to suffer the same issue. Although it seems to be triggered by testbed.

ch3

2018-11-02 15:48

developer   ~0013310

It actually seems to hit the newly introduced cache-size.

ch3

2018-11-02 15:50

developer   ~0013311

The cache-size seems to never be decreased.

Christian Grothoff

2018-11-02 15:53

manager   ~0013312

Should be fixed in edbb87266..c25fa6aba

Issue History

Date Modified Username Field Change
2018-11-02 14:12 ch3 New Issue
2018-11-02 14:12 ch3 Status new => assigned
2018-11-02 14:12 ch3 Assigned To => ch3
2018-11-02 14:28 ch3 Note Added: 0013309
2018-11-02 15:48 ch3 Note Added: 0013310
2018-11-02 15:50 ch3 Note Added: 0013311
2018-11-02 15:51 Christian Grothoff Assigned To ch3 => Christian Grothoff
2018-11-02 15:53 Christian Grothoff Note Added: 0013312
2018-11-02 15:54 Christian Grothoff Status assigned => resolved
2018-11-02 15:54 Christian Grothoff Resolution open => fixed
2018-11-02 15:54 Christian Grothoff Fixed in Version => 0.11.0
2018-11-02 15:54 Christian Grothoff Target Version => 0.11.0
2019-02-28 11:17 Christian Grothoff Status resolved => closed