View Issue Details

IDProjectCategoryView StatusLast Update
0005404libextractorlibextractor main librarypublic2018-11-04 11:24
ReporterlimbAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status closedResolutionno change required 
PlatformLinuxOSFedoraOS Version28+
Product Version1.7 
Target Version1.8Fixed in Version1.7 
Summary0005404: Build segfault
DescriptionCrashes during build on mock on Fedora 28 and up. Builds on local build.
Steps To ReproduceBuild local rpm of 1.7, then attempt build of SRPM in mock.
Additional InformationAttached patch corrects the issue.
TagsNo tags attached.

Activities

limb

2018-07-18 22:42

reporter  

libextractor-1.7-segfault.patch (617 bytes)
*** src/plugins/ole2_extractor.c~	2018-06-20 15:02:55.000000000 -0500
--- src/plugins/ole2_extractor.c	2018-07-18 15:21:13.411495048 -0500
***************
*** 336,342 ****
  	 (buf[1] != 0x0) ||
  	 (0 != strncmp (&buf[2],
  			"SfxDocumentInfo",
! 			strlen ("SfxDocumentInfo"))) ||
  	 (buf[0x11] != 0x0B) ||
  	 (buf[0x13] != 0x00) || /* pw protected! */
  	 (buf[0x12] != 0x00) )
--- 336,342 ----
  	 (buf[1] != 0x0) ||
  	 (0 != strncmp (&buf[2],
  			"SfxDocumentInfo",
! 			strlen ("SfxDocumentInfo") + 1)) ||
  	 (buf[0x11] != 0x0B) ||
  	 (buf[0x13] != 0x00) || /* pw protected! */
  	 (buf[0x12] != 0x00) )

Christian Grothoff

2018-08-05 22:21

manager   ~0013176

I can see why we should add the +1, but I right now do not see how this could possibly cause a crash, least of all a crash on build. Anyway, fixed in 426a4feb38645fc31e3530a51eef0f683f6e61ad

Christian Grothoff

2018-08-05 22:43

manager   ~0013178

Actually, after testing it is clear that the +1 does not work, as that string is NOT 0-terminated in the file. So the code breaks with the +1. Reverting, and I cannot understand why you say this crashes in either case.

limb

2018-08-06 15:31

reporter   ~0013183

I say it crashes because it crashes. What can I do to help troubleshoot?

Christian Grothoff

2018-08-06 15:46

manager   ~0013184

let's start with the full output of the crash: what you typed into the shell up to when you get your prompt back, i.e. attach the file you get when you run:

$ make install check &> output.txt

limb

2018-08-06 16:00

reporter   ~0013185

Here's a total mock build log.

build.log (99,490 bytes)

limb

2018-08-06 16:01

reporter   ~0013186

And here's what you requested.

output.txt (2,970 bytes)
Making install in m4
make[1]: Entering directory '/home/limb/fedora/git/libextractor/libextractor-1.7/m4'
make[2]: Entering directory '/home/limb/fedora/git/libextractor/libextractor-1.7/m4'
make[2]: Nothing to be done for 'install-exec-am'.
make[2]: Nothing to be done for 'install-data-am'.
make[2]: Leaving directory '/home/limb/fedora/git/libextractor/libextractor-1.7/m4'
make[1]: Leaving directory '/home/limb/fedora/git/libextractor/libextractor-1.7/m4'
Making install in po
make[1]: Entering directory '/home/limb/fedora/git/libextractor/libextractor-1.7/po'
/usr/bin/mkdir -p /usr/share
installing rw.gmo as /usr/share/locale/rw/LC_MESSAGES/libextractor.mo
installing fr.gmo as /usr/share/locale/fr/LC_MESSAGES/libextractor.mo
installing de.gmo as /usr/share/locale/de/LC_MESSAGES/libextractor.mo
installing ga.gmo as /usr/share/locale/ga/LC_MESSAGES/libextractor.mo
installing ro.gmo as /usr/share/locale/ro/LC_MESSAGES/libextractor.mo
installing sv.gmo as /usr/share/locale/sv/LC_MESSAGES/libextractor.mo
installing vi.gmo as /usr/share/locale/vi/LC_MESSAGES/libextractor.mo
installing nl.gmo as /usr/share/locale/nl/LC_MESSAGES/libextractor.mo
installing it.gmo as /usr/share/locale/it/LC_MESSAGES/libextractor.mo
installing uk.gmo as /usr/share/locale/uk/LC_MESSAGES/libextractor.mo
installing pl.gmo as /usr/share/locale/pl/LC_MESSAGES/libextractor.mo
installing sr.gmo as /usr/share/locale/sr/LC_MESSAGES/libextractor.mo
installing es.gmo as /usr/share/locale/es/LC_MESSAGES/libextractor.mo
if test "libextractor" = "gettext-tools"; then \
  /usr/bin/mkdir -p /usr/share/gettext/po; \
  for file in Makefile.in.in remove-potcdate.sin quot.sed boldquot.sed en@quot.header en@boldquot.header insert-header.sin Rules-quot   Makevars.template; do \
    /usr/bin/install -c -m 644 ./$file \
		    /usr/share/gettext/po/$file; \
  done; \
  for file in Makevars; do \
    rm -f /usr/share/gettext/po/$file; \
  done; \
else \
  : ; \
fi
make[1]: Leaving directory '/home/limb/fedora/git/libextractor/libextractor-1.7/po'
Making install in src
make[1]: Entering directory '/home/limb/fedora/git/libextractor/libextractor-1.7/src'
Making install in include
make[2]: Entering directory '/home/limb/fedora/git/libextractor/libextractor-1.7/src/include'
Making install in .
make[3]: Entering directory '/home/limb/fedora/git/libextractor/libextractor-1.7/src/include'
make[4]: Entering directory '/home/limb/fedora/git/libextractor/libextractor-1.7/src/include'
make[4]: Nothing to be done for 'install-exec-am'.
 /usr/bin/mkdir -p '/usr/include'
 /usr/bin/install -c -m 644 extractor.h '/usr/include'
make[4]: Leaving directory '/home/limb/fedora/git/libextractor/libextractor-1.7/src/include'
make[3]: Leaving directory '/home/limb/fedora/git/libextractor/libextractor-1.7/src/include'
make[2]: Leaving directory '/home/limb/fedora/git/libextractor/libextractor-1.7/src/include'
make[1]: Leaving directory '/home/limb/fedora/git/libextractor/libextractor-1.7/src'
output.txt (2,970 bytes)

Christian Grothoff

2018-11-04 11:23

manager   ~0013316

I've read it, this is a bug in your C compiler _with_ the "annobin" plugins (so most likely caused by the "annobin" plugins). It is _not_ a bug in libextractor. So please report it to the annobin developers!

Issue History

Date Modified Username Field Change
2018-07-18 22:42 limb New Issue
2018-07-18 22:42 limb File Added: libextractor-1.7-segfault.patch
2018-08-05 22:21 Christian Grothoff Note Added: 0013176
2018-08-05 22:21 Christian Grothoff Assigned To => Christian Grothoff
2018-08-05 22:21 Christian Grothoff Status new => assigned
2018-08-05 22:21 Christian Grothoff Status assigned => resolved
2018-08-05 22:21 Christian Grothoff Resolution open => fixed
2018-08-05 22:21 Christian Grothoff Fixed in Version => 1.8
2018-08-05 22:21 Christian Grothoff Target Version => 1.8
2018-08-05 22:43 Christian Grothoff Note Added: 0013178
2018-08-05 22:43 Christian Grothoff Assigned To Christian Grothoff =>
2018-08-05 22:43 Christian Grothoff Status resolved => feedback
2018-08-05 22:43 Christian Grothoff Resolution fixed => reopened
2018-08-05 22:44 Christian Grothoff Reproducibility always => unable to reproduce
2018-08-05 22:44 Christian Grothoff Fixed in Version 1.8 =>
2018-08-05 22:44 Christian Grothoff Target Version 1.8 =>
2018-08-06 15:31 limb Note Added: 0013183
2018-08-06 15:31 limb Status feedback => new
2018-08-06 15:46 Christian Grothoff Note Added: 0013184
2018-08-06 16:00 limb File Added: build.log
2018-08-06 16:00 limb Note Added: 0013185
2018-08-06 16:01 limb File Added: output.txt
2018-08-06 16:01 limb Note Added: 0013186
2018-11-04 11:23 Christian Grothoff Note Added: 0013316
2018-11-04 11:24 Christian Grothoff Assigned To => Christian Grothoff
2018-11-04 11:24 Christian Grothoff Status new => closed
2018-11-04 11:24 Christian Grothoff Resolution reopened => no change required
2018-11-04 11:24 Christian Grothoff Fixed in Version => 1.7
2018-11-04 11:24 Christian Grothoff Target Version => 1.8