View Issue Details

IDProjectCategoryView StatusLast Update
0005370GNUnetcadet servicepublic2019-02-13 23:29
Reporterch3Assigned ToChristian Grothoff 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformOSarchlinuxOS Version2018-06-27
Product Version0.11.0pre66 
Target Version0.11.0Fixed in Version0.11.0 
Summary0005370: Assertion Filures in cadet service
DescriptionObservation in the logs:

15:40:06-904712 cadet-5023 ERROR Assertion failed at gnunet-service-cadet_channel.c:1825.
15:40:06-904773 cadet-5023 ERROR Assertion failed at gnunet-service-cadet.c:764.
Steps To ReproduceRun rps tests (make check in src/rps/).
TagsNo tags attached.

Activities

Christian Grothoff

2018-06-28 10:29

manager   ~0013097

Hmm. This seems like a bug in flow control. cadet_api should enforce flow discipline and not send more messages than permitted, but the service here clearly asserts that it did. So either one of the two is misscounting :-(.

Christian Grothoff

2018-07-03 14:03

manager   ~0013132

Bart: this one would be great to have fixed, but likely will be (1) tricky to reproduce, (2) take a longer investigation to fix.

Christian Grothoff

2019-02-09 23:03

manager   ~0013638

I've read the code on both sides, and it seems entirely correct with respect to generating ACKs, counting ACKs and only sending messages in response to ACKs.

Christian Grothoff

2019-02-09 23:21

manager   ~0013639

I cannot reproduce this with the rps 'make check' either.

Christian Grothoff

2019-02-13 23:29

manager   ~0013723

Seems we cannot reproduce this one anymore. Reopen if we can.

Issue History

Date Modified Username Field Change
2018-06-27 17:25 ch3 New Issue
2018-06-27 17:25 ch3 Status new => assigned
2018-06-27 17:25 ch3 Assigned To => Bart Polot
2018-06-27 21:46 Christian Grothoff Relationship added related to 0005369
2018-06-27 21:47 Christian Grothoff Relationship added related to 0005367
2018-06-27 21:52 Christian Grothoff Severity minor => major
2018-06-28 10:22 Christian Grothoff Relationship deleted related to 0005367
2018-06-28 10:25 Christian Grothoff Relationship deleted related to 0005369
2018-06-28 10:29 Christian Grothoff Note Added: 0013097
2018-07-03 14:03 Christian Grothoff Note Added: 0013132
2018-07-07 00:26 Christian Grothoff Target Version => 0.11.0
2019-01-27 12:01 Christian Grothoff Assigned To Bart Polot =>
2019-01-27 12:01 Christian Grothoff Status assigned => confirmed
2019-02-09 23:03 Christian Grothoff Note Added: 0013638
2019-02-09 23:21 Christian Grothoff Note Added: 0013639
2019-02-09 23:22 Christian Grothoff Assigned To => ch3
2019-02-09 23:22 Christian Grothoff Status confirmed => feedback
2019-02-13 23:29 Christian Grothoff Assigned To ch3 => Christian Grothoff
2019-02-13 23:29 Christian Grothoff Status feedback => resolved
2019-02-13 23:29 Christian Grothoff Resolution open => unable to reproduce
2019-02-13 23:29 Christian Grothoff Fixed in Version => 0.11.0
2019-02-13 23:29 Christian Grothoff Note Added: 0013723