View Issue Details

IDProjectCategoryView StatusLast Update
0005320Talerotherpublic2019-09-16 09:12
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005320: consider using pipenv for easier "GNU-Style" installation of packages and deterministic builds
Descriptionpipenv (https://docs.pipenv.org/) is now officially recommended by the Python project, and allows easier management of virtualenvs and dependencies.

The idea with it would be to install each package into it's own virtualenv under $PREFIX, avoiding previous problems with the mess that is python's install paths.

This seems to be the "standard" solution to work around these problems.
TagsNo tags attached.

Activities

Florian Dold

2019-08-27 17:40

manager   ~0014815

We now use a more lightweight build system for the python packages that also supports GNU-style installation.

Pipenv is really mostly for setting up a development environment, and not really necessary for our use case.

Issue History

Date Modified Username Field Change
2018-04-09 13:35 Florian Dold New Issue
2018-04-09 13:42 Florian Dold Description Updated View Revisions
2018-09-15 11:08 Christian Grothoff Target Version 0.6 => 0.8
2019-08-27 17:40 Florian Dold Assigned To => Florian Dold
2019-08-27 17:40 Florian Dold Status new => resolved
2019-08-27 17:40 Florian Dold Resolution open => fixed
2019-08-27 17:40 Florian Dold Fixed in Version => SVN HEAD
2019-08-27 17:40 Florian Dold Note Added: 0014815
2019-09-16 09:12 Christian Grothoff Fixed in Version SVN HEAD => 0.6
2019-09-16 09:12 Christian Grothoff Target Version 0.8 => 0.6