View Issue Details

IDProjectCategoryView StatusLast Update
0005297GNUnetpeerinfo servicepublic2019-02-28 11:17
ReporterHeiko StamerAssigned Tong0 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSLinuxOS Version
Product VersionSVN HEAD 
Target Version0.11.0Fixed in Version0.11.0 
Summary0005297: Testsuite failed for peerinfo-tool
Description=====================================================
   gnunet 0.11.0: src/peerinfo-tool/test-suite.log
=====================================================

# TOTAL: 1
# PASS: 0
# SKIP: 0
# XFAIL: 0
# FAIL: 1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: test_gnunet_peerinfo.py
=============================

Mar 14 10:52:48-616885 peerinfo-28192 ERROR Assertion failed at gnunet-service-peerinfo.c:605.
Mar 14 10:52:48-616989 peerinfo-28192 ERROR Assertion failed at gnunet-service-peerinfo.c:605.
Mar 14 10:52:48-630086 nat-28195 ERROR UPnP enabled in configuration, but UPnP client `upnpc` command not found, disabling UPnP
Mar 14 10:52:49-693689 transport-28193 WARNING Failed to find plugin `udp'
Mar 14 10:52:49-693754 transport-28193 WARNING Failed to find plugin `udp'
Mar 14 10:52:49-693767 transport-28193 WARNING Failed to find plugin `udp'
Traceback (most recent call last):
  File "./test_gnunet_peerinfo.py", line 74, in <module>
    pinfo.expect ("stdout", re.compile ("Peer `.*'\r?\n"))
  File "../../contrib/gnunet_pyexpect.py", line 59, in expect
    m = r.search (stream.decode(), flags)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 74: ordinal not in range(128)
FAIL test_gnunet_peerinfo.py (exit status: 1)
TagsNo tags attached.

Activities

Christian Grothoff

2018-03-16 22:41

manager   ~0012888

Hmm. The assertion failure suggests that your installation is somehow broken, as there is a malformed file in the hello directory (maybe from an ancient earlier version?).

Also, you must run 'make install' before running 'make check', which is most likely why the UDP plugin is not found, causing the rest of the logic to go bonkers.

Heiko Stamer

2018-03-17 09:48

reporter   ~0012890

Unfortunately, a 'make clean' and 'make install' does not help here. The error messages are the same. Next I'll try to make a fresh 'git clone' and bootstrap of the repository...

Heiko Stamer

2018-03-17 10:44

reporter   ~0012891

Again the error remains. However, remind that I have reported a similar error before: https://gnunet.org/bugs/view.php?id=5094

=====================================================
   gnunet 0.11.0: src/peerinfo-tool/test-suite.log
=====================================================

# TOTAL: 1
# PASS: 0
# SKIP: 0
# XFAIL: 0
# FAIL: 1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: test_gnunet_peerinfo.py
=============================

Mar 17 10:31:08-374064 nat-21336 ERROR UPnP enabled in configuration, but UPnP client `upnpc` command not found, disabling UPnP
Mar 17 10:31:09-445448 transport-21334 WARNING Failed to find plugin `udp'
Mar 17 10:31:09-445541 transport-21334 WARNING Failed to find plugin `udp'
Mar 17 10:31:09-445565 transport-21334 WARNING Failed to find plugin `udp'
Traceback (most recent call last):
  File "./test_gnunet_peerinfo.py", line 74, in <module>
    pinfo.expect ("stdout", re.compile ("Peer `.*'\r?\n"))
  File "../../contrib/gnunet_pyexpect.py", line 59, in expect
    m = r.search (stream.decode(), flags)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 430: ordinal not in range(128)
FAIL test_gnunet_peerinfo.py (exit status: 1)

ng0

2018-05-22 12:56

developer   ~0012943

Last edited: 2018-05-22 12:59

View 2 revisions

Notice that 'make clean' unfortunately does not clean everything at the moment.
Furthermore, which python version do you run?
Could you provide an output of contrib/scripts/report.sh

Thanks


e: Your error reads like you are using python3, which is currently not fully supported [I'm working on py>=2.7 + >=3.6 (or what the not so problematic versions of 3.x was) support at the moment].
Is this correct?

Heiko Stamer

2018-05-26 21:33

reporter   ~0012962

Python 2.7.14

Please have a look at https://gnunet.org/bugs/view.php?id=5094

ng0

2019-02-12 01:56

developer   ~0013663

This looks like another py2/3 part to fix, if it's still relevant. I lost track of some tasks, sorry.

ng0

2019-02-13 15:49

developer   ~0013701

I can not reproduce this with python3.7

Since we are moving to python3.7 with the testsuite: if there are any python2.7 errors left after 0005560 is done, please send forwards-compatible patches if your system does not support python3.7.

Christian Grothoff

2019-02-13 16:44

manager   ~0013704

Could we modify the build system to only run the Py tests if 3.7 is available?

Issue History

Date Modified Username Field Change
2018-03-14 11:36 Heiko Stamer New Issue
2018-03-16 22:41 Christian Grothoff Note Added: 0012888
2018-03-17 09:48 Heiko Stamer Note Added: 0012890
2018-03-17 10:44 Heiko Stamer Note Added: 0012891
2018-05-22 12:56 ng0 Note Added: 0012943
2018-05-22 12:59 ng0 Note Edited: 0012943 View Revisions
2018-05-22 13:30 ng0 Assigned To => ng0
2018-05-22 13:30 ng0 Status new => assigned
2018-05-22 13:30 ng0 Status assigned => feedback
2018-05-26 21:33 Heiko Stamer Note Added: 0012962
2018-05-26 21:33 Heiko Stamer Status feedback => assigned
2019-02-12 01:56 ng0 Note Added: 0013663
2019-02-13 15:49 ng0 Status assigned => resolved
2019-02-13 15:49 ng0 Resolution open => fixed
2019-02-13 15:49 ng0 Fixed in Version => SVN HEAD
2019-02-13 15:49 ng0 Note Added: 0013701
2019-02-13 16:44 Christian Grothoff Note Added: 0013704
2019-02-13 16:45 Christian Grothoff Fixed in Version SVN HEAD => 0.11.0
2019-02-13 16:45 Christian Grothoff Target Version => 0.11.0
2019-02-28 11:17 Christian Grothoff Status resolved => closed