View Issue Details

IDProjectCategoryView StatusLast Update
0005275Talerexchangepublic2018-04-15 20:35
ReporterFlorian DoldAssigned ToFlorian Dold 
PriorityurgentSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.5Fixed in Version0.5 
Summary0005275: taler-exchange-wirewatch still causing problems on demo
DescriptionFeb 07 02:17:15-476266 taler-exchange-wirewatch-24831 ERROR Assertion failed at plugin_wire_test.c:958.
Feb 07 02:17:15-476377 taler-exchange-wirewatch-24831 ERROR Failed to start request for account history!
TagsNo tags attached.

Activities

Florian Dold

2018-02-11 17:15

manager   ~0012859

The explanation for this is *probably* an outdated version of the reserve top-up script running via cron.

Bogus records were inserted into the reserves_in table (with the wire_reference column sometimes having values of size 30, when the test wire plugin would expect it to be an 8-byte value).

Christian Grothoff

2018-02-22 18:07

manager   ~0012869

Why is this still open? I thought Florian told me he fixed this.

Florian Dold

2018-02-22 18:10

manager   ~0012870

Yes, I wanted to keep it open for a while to see if the problem is fixed now, since previously I *thought* it was fixed when the issue still occurred.

Now it looks fine, from the wirewatch logs.

Issue History

Date Modified Username Field Change
2018-02-07 02:27 Florian Dold New Issue
2018-02-07 02:27 Florian Dold Status new => assigned
2018-02-07 02:27 Florian Dold Assigned To => Florian Dold
2018-02-11 17:15 Florian Dold Note Added: 0012859
2018-02-22 18:07 Christian Grothoff Note Added: 0012869
2018-02-22 18:10 Florian Dold Status assigned => resolved
2018-02-22 18:10 Florian Dold Resolution open => fixed
2018-02-22 18:10 Florian Dold Note Added: 0012870
2018-04-15 20:35 Christian Grothoff Fixed in Version => 0.5
2018-04-15 20:35 Christian Grothoff Status resolved => closed