View Issue Details

IDProjectCategoryView StatusLast Update
0005271Talerexchangepublic2018-04-15 20:35
ReporterFlorian DoldAssigned ToFlorian Dold 
PriorityhighSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.5Fixed in Version0.5 
Summary0005271: taler-exchange-wirewatch -r always crashes
Descriptiondemo-blue@tripwire:~$ taler-exchange-wirewatch -t test -r
Feb 05 16:18:51-236982 pq-30488 ERROR Query `reserve_get' failed with result: current transaction is aborted, commands ignored until end of transaction block/(null)/ERROR: current transaction is aborted, commands ignored until end of transaction block
/PGRES_FATAL_ERROR/ERROR: current transaction is aborted, commands ignored until end of transaction block

Feb 05 16:18:51-237068 taler-exchange-wirewatch-30488 ERROR Assertion failed at plugin_exchangedb_postgres.c:1815.
Feb 05 16:18:51-237086 taler-exchange-wirewatch-30488 ERROR Assertion failed at taler-exchange-wirewatch.c:390.
Segmentation fault
TagsNo tags attached.

Activities

Florian Dold

2018-02-05 17:48

manager   ~0012857

Actually it only crashes when the reserves table is not empty, it's caused by the following wrong assumption:

/* Create new incoming transaction, SQL "primary key" logic
   is used to guard against duplicates. If a duplicate is
   detected, we just "succeed" with no changes. */

Florian Dold

2018-02-05 21:50

manager   ~0012858

Fixed in 48fd50f922a7385dfd4.

Issue History

Date Modified Username Field Change
2018-02-05 16:23 Florian Dold New Issue
2018-02-05 16:23 Florian Dold Status new => assigned
2018-02-05 16:23 Florian Dold Assigned To => Christian Grothoff
2018-02-05 16:29 Florian Dold Summary taler-exchange-wirewatch -r produces => taler-exchange-wirewatch -r always crashes
2018-02-05 17:48 Florian Dold Note Added: 0012857
2018-02-05 21:50 Florian Dold Assigned To Christian Grothoff => Florian Dold
2018-02-05 21:50 Florian Dold Status assigned => resolved
2018-02-05 21:50 Florian Dold Resolution open => fixed
2018-02-05 21:50 Florian Dold Note Added: 0012858
2018-04-15 20:35 Christian Grothoff Fixed in Version => 0.5
2018-04-15 20:35 Christian Grothoff Status resolved => closed