View Issue Details

IDProjectCategoryView StatusLast Update
0005247GNUnetbuild processpublic2019-02-28 11:17
Reporterng0Assigned Tong0 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionwon't fix 
Product Version 
Target Version0.11.0Fixed in Version0.11.0 
Summary0005247: Rewrite python tests in pytest
DescriptionOverview, this should be split up into multiple tickets:

While looking into the possibility of rewriting the python scripts to python3 *and* python2 (right now it's just python2), I found out that it's easier to start from 0 with standards we have now for test suites in Python.

Implementing python2 + python3 from the beginning on is not an hard requirement, you could write it for 3 and add support for python2 later on (while it's still around).

My initial idea was to move repetive code out into the - so far unused - https://gnunet.org/git/gnunet-testsuite-helper-functions.git/ repository. The python module contained in there would then become a requirement for the testsuite of GNUnet. In addition to this module (or in place for this module) we could implement gnunet specific pytest functions so that we can easily write new tests and encourage people to contribute tests in a language they already know.

If the functions (the ones that are not test related) are generic enough, we could also reuse them in the gnunet-python repository and other python repositories in our infrastructure.

We would also implement checks for PEP and other linting as the current files weren't really good to read.





I'm putting this up for grabs as currently I have too much to do to work on this any time soon. If anyone asigns this to themselves before I get back to work on this, I know which person to talk to for collaboration.


Check out the python related branch, I might push some last commits there and some early commits to the other repos mentioned here.
TagsNo tags attached.

Activities

ng0

2018-01-05 23:06

developer   ~0012735

The reason why I want to move code out into modules is that it's easier on the system side to deal with this, and it can be reused with the possibility of even providing a pytest kind of template for the gnunet-extension (or what our 'get started' LEGO brick in a repo is called again).

ng0

2018-05-22 13:29

developer   ~0012947

I have mixed feelings about relying on an external testsuite framework.
It introduces yet another dependency, and so far the tests work.

I'll look into this after adding py2+3 dual support.

ng0

2018-11-04 17:49

developer   ~0013321

Resolution was to get python out, as discussed on-list, off-list, or somewhere else.

Issue History

Date Modified Username Field Change
2018-01-05 22:54 ng0 New Issue
2018-01-05 23:06 ng0 Note Added: 0012735
2018-01-12 12:20 Christian Grothoff Severity minor => feature
2018-05-22 13:29 ng0 Note Added: 0012947
2018-05-22 13:29 ng0 Assigned To => ng0
2018-05-22 13:29 ng0 Status new => assigned
2018-11-04 17:49 ng0 Status assigned => resolved
2018-11-04 17:49 ng0 Resolution open => won't fix
2018-11-04 17:49 ng0 Note Added: 0013321
2019-02-12 09:20 Christian Grothoff Target Version => 0.11.0
2019-02-20 12:24 Christian Grothoff Fixed in Version => 0.11.0
2019-02-28 11:17 Christian Grothoff Status resolved => closed