View Issue Details

IDProjectCategoryView StatusLast Update
0005243GNUnetfile-sharing servicepublic2019-02-28 11:17
ReporterxrsAssigned Toxrs 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSarchlinuxOS Versionhead
Product Version0.11.0pre66 
Target Version0.11.0Fixed in Version0.11.0 
Summary0005243: make check for fs/test_gnunet_fs_psd.py fails
DescriptionRunning fs/test_gnunet_fs_psd.py with python3 and python2.7 fails.
Steps To Reproduce$ cd fs
$ make check

Also executed (python3 is default):
./test_gnunet_fs_psd.py
Traceback (most recent call last):
  File "./test_gnunet_fs_psd.py", line 29, in <module>
    reload(sys)
NameError: name 'reload' is not defined


Also executed:
$ python2.7 test_gnunet_fs_psd.py
Failed to find `Publishing `.+test_gnunet_fs_rec_data.tgz' done\.\r?\n' in stdout, which is is `Jan 04 01:43:01-816857 util-disk-26970 WARNING `stat' failed on file `/home/xrs/sources/gnunet/src/util/.libs/share/gnunet/config.d' at disk.c:1240 with error: No such file or directory
Jan 04 01:43:01-816923 gnunet-publish-26970 ERROR Malformed configuration file `/home/xrs/sources/gnunet/src/fs/test_gnunet_fs_psd_data.conf', exit ...
'
Additional InformationI have investigated why test_gnunet_fs_psd_data.conf is malformed. But I couldn't see anything wrong. See uploaded file.
TagsNo tags attached.

Activities

xrs

2018-01-04 02:04

developer  

test_gnunet_fs_psd_data.conf (112 bytes)

Christian Grothoff

2018-01-12 12:14

manager   ~0012771

Ah, for Python 2.7, you are running the test by hand, without having set "GNUNET_PREFIX" (usually 'make check' does that). That is why your configuration file is "malformed".

For python 3, there seems to be an issue with the 'reload' symbol.

ng0

2018-05-22 13:09

developer   ~0012944

Line 29 is a comment preceding the code:
# python3.4:

So you will need at least python 3.4 when you use python3.
library reference: https://docs.python.org/3/library/importlib.html?highlight=importlib#importlib.reload

version support excurs/rant: There was a certain set of problematic (wrt py2/3 duality) python 3 version, so once I'm done with bringing the python files on par with reality, I will let configure check for 2 minimum versions. For 2, that will be at least 2.7.15 (the very last python 2 release iirc) and for 3 I don't know currently. Everything else sucks too much to support.

ng0

2018-05-22 13:21

developer   ~0012945

I have the following suggestion, which will eventually go into the bag of functions for generalized test suite imports:



if "GNUNET_PREFIX" in os.environ:
     pass
else:
     sys.exit(1)



So if the env variable is not set, break hard and exit. Other continue.
Okay?

Christian Grothoff

2018-06-07 23:31

manager   ~0013026

Sure, feel free to add that.

ng0

2018-06-14 20:53

developer   ~0013041

should be fixed in https://gnunet.org/git/gnunet.git/commit/?id=07edbcab2e3915e8898680d38596537c128b10dc plus follow-up commit.

xrs

2018-06-23 16:48

developer   ~0013059

After having still some errors under python 3 (3.6.5) I added compatibily code for python 3.

Issue History

Date Modified Username Field Change
2018-01-04 02:04 xrs New Issue
2018-01-04 02:04 xrs File Added: test_gnunet_fs_psd_data.conf
2018-01-12 11:50 Christian Grothoff Assigned To => Christian Grothoff
2018-01-12 11:50 Christian Grothoff Status new => assigned
2018-01-12 11:50 Christian Grothoff Target Version => 0.11.0pre66
2018-01-12 12:14 Christian Grothoff Note Added: 0012771
2018-01-12 12:14 Christian Grothoff Assigned To Christian Grothoff =>
2018-01-12 12:14 Christian Grothoff Status assigned => feedback
2018-05-22 13:09 ng0 Note Added: 0012944
2018-05-22 13:21 ng0 Note Added: 0012945
2018-06-07 23:31 Christian Grothoff Note Added: 0013026
2018-06-07 23:31 Christian Grothoff Assigned To => ng0
2018-06-07 23:31 Christian Grothoff Status feedback => assigned
2018-06-14 20:52 ng0 Status assigned => acknowledged
2018-06-14 20:53 ng0 Status acknowledged => resolved
2018-06-14 20:53 ng0 Resolution open => fixed
2018-06-14 20:53 ng0 Note Added: 0013041
2018-06-23 15:11 xrs Assigned To ng0 => xrs
2018-06-23 15:11 xrs Status resolved => feedback
2018-06-23 15:11 xrs Resolution fixed => reopened
2018-06-23 16:48 xrs Note Added: 0013059
2018-06-23 16:49 xrs Status feedback => resolved
2018-06-23 16:49 xrs Resolution reopened => fixed
2018-06-23 16:49 xrs Fixed in Version => SVN HEAD
2019-02-03 09:47 Christian Grothoff Product Version SVN HEAD => 0.11.0pre66
2019-02-03 09:47 Christian Grothoff Fixed in Version SVN HEAD => 0.11.0
2019-02-03 09:47 Christian Grothoff Target Version 0.11.0pre66 => 0.11.0
2019-02-28 11:17 Christian Grothoff Status resolved => closed