View Issue Details

IDProjectCategoryView StatusLast Update
0005207Talerotherpublic2019-09-16 09:10
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritylowSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005207: offer high-level merchant integration in addition to the current low-level integration
DescriptionCurrently offering payments with Taler is not as easy as it could be (and not as easy as with some other payment providers). We need to set headers, implement quite a lot of endpoints and know too many details of how the protocol works.

This is fine for our demos, but we could make it even easier, by offering a merchant-as-a-service component that takes over some duties that currently the frontend has to do.

It would offer mostly just two end-points:
1) create an order: returns an order_id and a URL that's served by the merchant-as-a-service component which will trigger the payment and take care of all the details (headers, contract generation, etc.)
2) check if an offer_id has been paid for, returns the contract terms and either "yes" or the URL to redirect the user to that will make the payment happen

Additionally we can allow payments even on *static* websites, by POSTing a form to the merchant-as-a-service component. This is useful either for donations or for products that will be physically/individually be delivered. If the seller runs out of stock, they can give a refund in the web interface.

The difference to the "low-level integration" that we currently have is that the merchant-as-a-service serves pages to the browser and the wallet directly.
TagsNo tags attached.

Relationships

duplicate of 0005870 new update codeless payments to new API, deploy on gv 

Activities

Florian Dold

2017-12-09 22:21

manager   ~0012648

Oh and of course this would not be a new backend, but just a new "frontend with an API" that talks to the current backend with the low-level API.

Maybe a nice project for somebody who wants to work on Taler, who's pretty new and wants to do rather high-level things.

Florian Dold

2019-09-01 18:39

manager   ~0014830

All this is covered by the codeless merchant.

Issue History

Date Modified Username Field Change
2017-12-09 22:14 Florian Dold New Issue
2017-12-09 22:15 Florian Dold Description Updated View Revisions
2017-12-09 22:21 Florian Dold Note Added: 0012648
2019-09-01 18:39 Florian Dold Assigned To => Florian Dold
2019-09-01 18:39 Florian Dold Status new => resolved
2019-09-01 18:39 Florian Dold Resolution open => duplicate
2019-09-01 18:39 Florian Dold Note Added: 0014830
2019-09-01 18:39 Florian Dold Relationship added duplicate of 0005870
2019-09-16 09:10 Christian Grothoff Product Version => SVN HEAD
2019-09-16 09:10 Christian Grothoff Fixed in Version => 0.6
2019-09-16 09:10 Christian Grothoff Target Version => 0.6