View Issue Details

IDProjectCategoryView StatusLast Update
0005052Talerwallet (WebExtensions)public2017-06-06 14:18
ReporterChristian GrothoffAssigned ToFlorian Dold 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.3Fixed in Version0.3 
Summary0005052: demo.taler.net shows wallet as installed only after refresh (F5)
DescriptionI had the wallet already installed, went to demo.taler.net, and got the "wallet not installed" version. Then I hit "F5" and I got the "Congrats".

This is with Chromium.
TagsNo tags attached.

Activities

Christian Grothoff

2017-06-01 23:17

manager   ~0012205

More funky: on the bank page (after logging in), I can push F5 to (sometimes) toggle between wallet found & wallet not-found. Oopsie.

Florian Dold

2017-06-02 02:18

manager   ~0012206

Fixed in a6035dd4.

Pretty easy to explain why this happened, and probably happened because we've moved quite some code around.

We check for the data-taler-nojs attribute to enable stylesheet injection for presence detection. Unfortunately this attribute was checked before we made sure the DOM was loaded, so sometimes the content script was "too fast" and stylesheets weren't injected.

Issue History

Date Modified Username Field Change
2017-06-01 23:16 Christian Grothoff New Issue
2017-06-01 23:16 Christian Grothoff Status new => assigned
2017-06-01 23:16 Christian Grothoff Assigned To => Florian Dold
2017-06-01 23:17 Christian Grothoff Note Added: 0012205
2017-06-02 02:18 Florian Dold Note Added: 0012206
2017-06-02 02:18 Florian Dold Status assigned => resolved
2017-06-02 02:18 Florian Dold Resolution open => fixed
2017-06-02 09:34 Christian Grothoff Fixed in Version => 0.3
2017-06-06 14:18 Christian Grothoff Status resolved => closed