View Issue Details

IDProjectCategoryView StatusLast Update
0005040Talerwallet (WebExtensions)public2017-06-06 14:18
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.3Fixed in Version0.3 
Summary0005040: use wallet api lib instead of duplicated helpers in content script, since dead code elimination is available now
DescriptionWe still have custom, duplicate helper functions in the content script, from the time where we weren't using a module bundler (but SystemJS).

Since dead code elimination now should work, we can just use the libraries we have, removing duplication and making the code more readable.
TagsNo tags attached.

Relationships

related to 0005041 closedFlorian Dold do not allow the merchant to directly send proposal to wallet, which could circumvent nonce check 

Activities

Florian Dold

2017-05-31 17:11

manager   ~0012200

Fixed around 613a14c14.

Issue History

Date Modified Username Field Change
2017-05-29 12:58 Florian Dold New Issue
2017-05-29 12:58 Florian Dold Status new => assigned
2017-05-29 12:58 Florian Dold Assigned To => Florian Dold
2017-05-29 13:34 Florian Dold Relationship added related to 0005041
2017-05-31 17:11 Florian Dold Status assigned => resolved
2017-05-31 17:11 Florian Dold Resolution open => fixed
2017-05-31 17:11 Florian Dold Note Added: 0012200
2017-06-02 09:35 Christian Grothoff Product Version => SVN HEAD
2017-06-02 09:35 Christian Grothoff Fixed in Version => 0.3
2017-06-02 09:35 Christian Grothoff Target Version => 0.3
2017-06-06 14:18 Christian Grothoff Status resolved => closed