View Issue Details

IDProjectCategoryView StatusLast Update
0005037Talertaler-wallet-libpublic2017-06-06 14:18
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.3Fixed in Version0.3 
Summary0005037: clean up code in taler-wallet-lib that better belongs in the extensions' content script
DescriptionWe still have code to download the proposal in taler-wallet-lib, this is duplicated in the wallet (which doesn't include taler-wallet-lib anymore), this duplication should be removed.
TagsNo tags attached.

Activities

Florian Dold

2017-05-29 02:15

manager   ~0012178

Specifically due to the nonce mechanism, the merchant shouldn't be able to just give a proposal to the wallet. This can be handled entirely in the content script.

Florian Dold

2017-06-01 18:47

manager   ~0012203

Fixed in ebf2b43fb

Issue History

Date Modified Username Field Change
2017-05-29 02:03 Florian Dold New Issue
2017-05-29 02:15 Florian Dold Note Added: 0012178
2017-05-29 02:16 Florian Dold Assigned To => Florian Dold
2017-05-29 02:16 Florian Dold Status new => assigned
2017-05-29 02:16 Florian Dold Target Version => 0.3
2017-06-01 18:47 Florian Dold Status assigned => resolved
2017-06-01 18:47 Florian Dold Resolution open => fixed
2017-06-01 18:47 Florian Dold Note Added: 0012203
2017-06-02 09:34 Christian Grothoff Product Version => SVN HEAD
2017-06-02 09:34 Christian Grothoff Fixed in Version => 0.3
2017-06-06 14:18 Christian Grothoff Status resolved => closed