View Issue Details

IDProjectCategoryView StatusLast Update
0005034Talerwallet (WebExtensions)public2017-06-06 14:18
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.3Fixed in Version0.3 
Summary0005034: use cross-environment threading library so that wallet crypto thread works in both browser and node.js
DescriptionRight now we're using web workers, but they don't work in node. The thread.js library supports both.
TagsNo tags attached.

Activities

Florian Dold

2017-05-27 14:56

manager   ~0012160

Right now this would be very useful for testing, since we don't have to run a full browser for the test cases.

Florian Dold

2017-05-28 22:41

manager   ~0012172

Done, the cryptoApi (which accesses a WebWorker) now also runs properly in node. We now can test the cryptoApi with normal unit tests without selenium.

Issue History

Date Modified Username Field Change
2017-05-27 14:53 Florian Dold New Issue
2017-05-27 14:53 Florian Dold Status new => assigned
2017-05-27 14:53 Florian Dold Assigned To => Florian Dold
2017-05-27 14:56 Florian Dold Note Added: 0012160
2017-05-27 15:19 Florian Dold Summary use thread.js so that wallet crypto thread works in both browser and node.js => use cross-environment threading library so that wallet crypto thread works in both browser and node.js
2017-05-28 22:41 Florian Dold Note Added: 0012172
2017-05-28 22:41 Florian Dold Status assigned => resolved
2017-05-28 22:41 Florian Dold Resolution open => fixed
2017-05-28 22:54 Christian Grothoff Severity minor => tweak
2017-05-28 22:54 Christian Grothoff Product Version => SVN HEAD
2017-05-28 22:54 Christian Grothoff Fixed in Version => 0.3
2017-05-28 22:54 Christian Grothoff Target Version => 0.3
2017-06-06 14:18 Christian Grothoff Status resolved => closed