View Issue Details

IDProjectCategoryView StatusLast Update
0005032Talerwallet (WebExtensions)public2017-06-06 14:18
ReporterChristian GrothoffAssigned ToFlorian Dold 
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.3Fixed in Version0.3 
Summary0005032: wallet complains: Error: exception (superfluous properties ["payback"])
DescriptionUsing the 0.2.2 wallet against the latest exchange, I get the above error when /keys is requested (where the payback array is empty, but the member is present).

I _suspect_ this is an older version of the wallet, even though there isn't a newer one on the site(s).

Regardless, I wanted to question that we die hard under this circumstance (withdraw is no longer possible), as this will prevent us from easily extending the protocol with additional information. Naturally, if there is a future version of the protocol and /keys has more information it is not good if the wallet doesn't understand it, but I think a _warning_ may be more appropriate in this case ("property XXX not understood, maybe you should update your wallet?") and _allowing_ the user to proceed anyway. WDYT?
TagsNo tags attached.

Activities

Florian Dold

2017-05-25 02:00

manager   ~0012157

Yeah, it makes sense to turn off the strict validation for the contract. I think we should do this selectively though, an amount for example should never have extra fields.

Christian Grothoff

2017-05-25 02:05

manager   ~0012158

Eh, to be clear: this is not the contract, this is /keys.

Florian Dold

2017-05-27 15:08

manager   ~0012161

Resolved in 41f152b. I don't think it's a good idea to include the "maybe you should update your wallet" based on this though.

If we really want this, the exchange should publish some wallet_protocol field in /keys and if the wallet wants it can check it.

Printing this warning for extra fields is bad, since a newer wallet could also remove support for deprecated fields and the exchange could be too old!

Issue History

Date Modified Username Field Change
2017-05-24 23:43 Christian Grothoff New Issue
2017-05-24 23:43 Christian Grothoff Status new => assigned
2017-05-24 23:43 Christian Grothoff Assigned To => Florian Dold
2017-05-25 02:00 Florian Dold Note Added: 0012157
2017-05-25 02:05 Christian Grothoff Note Added: 0012158
2017-05-27 15:08 Florian Dold Status assigned => resolved
2017-05-27 15:08 Florian Dold Resolution open => fixed
2017-05-27 15:08 Florian Dold Note Added: 0012161
2017-05-28 23:01 Christian Grothoff Fixed in Version => 0.3
2017-06-06 14:18 Christian Grothoff Status resolved => closed