View Issue Details

IDProjectCategoryView StatusLast Update
0004988GNUnetgnunet-setuppublic2019-02-28 11:17
ReporterellAssigned ToChristian Grothoff 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionfixed 
Platformx86_64 GNU/LinuxOSSMP Debian 3.16.39-1+deb8u2 OS Version
Product VersionSVN HEAD 
Target Version0.11.0Fixed in Version0.11.0 
Summary0004988: can't get gnunet-setup to work
DescriptionThere are no gnunet processes running - then
I do

gnunet-setup ->transport->tcp

and I can see when
testing gnunet-setup with wireshark that gnunet.org
sends TCP-packets

Transmission Control Protocol, Src Port: omsdk (5724), Dst Port: 35925 (35925), Seq: 1, Ack: 1, Len: 0

Question: Is omsdk a non-gnu-software? Is there a similiar Linux software
for my box to listen on TCP 35925? Or how should gnunet or gnunet-gtk be modified?

The TCP-Packets come from
Internet Protocol Version 4, Src: gnunet.org (131.159.74.67), Dst: deb-gnunet-fce-8.vbd (192.168.22.10)



Additional InformationIn early gnunet-versions gnunet-setup was ok. No problems from my local net.
TagsNo tags attached.

Activities

Christian Grothoff

2017-04-30 12:55

manager   ~0012088

The GNUnet process that sends the packets is part of the GNUnet installation, it's the "gnunet-nat-server" which you can find in src/nat-auto/ in the GNUnet code. We just happened to use the port of "omsdk", but this has nothing to do with "omsdk".

Christian Grothoff

2017-04-30 12:55

manager   ~0012089

(As for gnunet-setup not working, I'll need some time to re-test it under different conditions.)

Christian Grothoff

2019-02-12 19:12

manager   ~0013690

Due to changes in the configuration syntax, the gnunet-nat-server was no longer running on gnunet.org. I've fixed that now.

Issue History

Date Modified Username Field Change
2017-04-13 15:54 ell New Issue
2017-04-30 12:55 Christian Grothoff Note Added: 0012088
2017-04-30 12:55 Christian Grothoff Note Added: 0012089
2017-05-04 22:34 Christian Grothoff Assigned To => Christian Grothoff
2017-05-04 22:34 Christian Grothoff Status new => assigned
2018-06-07 01:14 Christian Grothoff Assigned To Christian Grothoff =>
2018-06-07 01:14 Christian Grothoff Status assigned => confirmed
2019-02-12 08:57 Christian Grothoff Assigned To => Christian Grothoff
2019-02-12 08:57 Christian Grothoff Status confirmed => assigned
2019-02-12 19:12 Christian Grothoff Status assigned => resolved
2019-02-12 19:12 Christian Grothoff Resolution open => fixed
2019-02-12 19:12 Christian Grothoff Fixed in Version => 0.11.0
2019-02-12 19:12 Christian Grothoff Note Added: 0013690
2019-02-12 19:12 Christian Grothoff Target Version => 0.11.0
2019-02-28 11:17 Christian Grothoff Status resolved => closed