View Issue Details

IDProjectCategoryView StatusLast Update
0004969gnunet-gtkbuild systempublic2018-06-07 00:24
ReporterellAssigned ToChristian Grothoff 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformDebian-8.7.1, amd64OSOS Version
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0004969: make dies
Descriptiongit clone https://gnunet.org/git/gnunet/
cd gnunet-gtk
./bootstrap
./configure --with-gnunet=/usr/local
make
.....
make[4]: Entering directory '/home/ell/Schreibtisch/gnunet-gtk/src/setup'
gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../.. -I../../ -I../../src/include -pthread -I/usr/local/include/gtk-3.0 -I/usr/local/include/gio-unix-2.0/ -I/usr/local/include/pango-1.0 -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -I/usr/include/cairo -I/usr/include/harfbuzz -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng12 -pthread -I/usr/local/include/gtk-3.0 -I/usr/local/include/gio-unix-2.0/ -I/usr/local/include/pango-1.0 -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -I/usr/include/cairo -I/usr/include/harfbuzz -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng12 -I/usr/local/include -pthread -I/usr/local/include/gtk-3.0 -I/usr/local/include/gio-unix-2.0/ -I/usr/local/include/pango-1.0 -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -I/usr/include/cairo -I/usr/include/harfbuzz -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng12 -I/usr/include/libxml2 -I/usr/include/libgladeui-2.0 -fno-strict-aliasing -Wall -g -O2 -pthread -I/usr/local/include/gtk-3.0 -I/usr/local/include/gio-unix-2.0/ -I/usr/local/include/pango-1.0 -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -I/usr/include/cairo -I/usr/include/harfbuzz -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng12 -MT gnunet_setup-gnunet-setup.o -MD -MP -MF .deps/gnunet_setup-gnunet-setup.Tpo -c -o gnunet_setup-gnunet-setup.o `test -f 'gnunet-setup.c' || echo './'`gnunet-setup.c
gnunet-setup.c: In function ‘main’:
gnunet-setup.c:524:11: error: ‘GNUNET_GETOPT_set_one’ undeclared (first use in this function)
       0, &GNUNET_GETOPT_set_one, &do_gksu },
           ^
gnunet-setup.c:524:11: note: each undeclared identifier is reported only once for each function it appears in
gnunet-setup.c:524:7: warning: initialization from incompatible pointer type
       0, &GNUNET_GETOPT_set_one, &do_gksu },
       ^
gnunet-setup.c:524:7: warning: (near initialization for ‘options[0].processor’)
Makefile:580: recipe for target 'gnunet_setup-gnunet-setup.o' failed
make[4]: *** [gnunet_setup-gnunet-setup.o] Error 1
make[4]: Leaving directory '/home/ell/Schreibtisch/gnunet-gtk/src/setup'
Makefile:830: recipe for target 'all-recursive' failed
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory '/home/ell/Schreibtisch/gnunet-gtk/src/setup'
Makefile:400: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/home/ell/Schreibtisch/gnunet-gtk/src'
Makefile:543: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/ell/Schreibtisch/gnunet-gtk'
Makefile:426: recipe for target 'all' failed
make: *** [all] Error 2
Additional Informationgnunet resides in /usr/local and seems to be ok.

There are two code-snippeds:
GNUNET_GETOPT_set_one
in gnunet-gtk used in
src/peerinfo/gnunet-peerinfo-gtk.c
src/setup/gnunet-setup.c

and
GNUNET_GETOPT_OPTION_SET_ONE
in gnunet from src/include/gnunet_getopt_lib.h
TagsNo tags attached.

Activities

ell

2017-03-23 17:21

reporter   ~0011966

It seems to work with

gnunet-gtk$ ./configure --with-gnunet=/usr/local --with-gnutls=/usr/local --with-glade=/usr/local --disable-setup-app --disable-peerinfo-app --disable-conversation-app

but this is not what I want.

ng0

2017-03-25 02:55

developer   ~0011974

I can confirm an equal error on Guix with my package.

Christian Grothoff

2017-03-25 21:13

manager   ~0011976

Fixed in b5efc114..8d8de6b9

Issue History

Date Modified Username Field Change
2017-03-23 09:19 ell New Issue
2017-03-23 17:21 ell Note Added: 0011966
2017-03-25 02:55 ng0 Note Added: 0011974
2017-03-25 20:22 Christian Grothoff Assigned To => Christian Grothoff
2017-03-25 20:22 Christian Grothoff Status new => assigned
2017-03-25 20:22 Christian Grothoff Product Version => SVN HEAD
2017-03-25 20:22 Christian Grothoff Target Version => 0.11.0pre66
2017-03-25 21:13 Christian Grothoff Status assigned => resolved
2017-03-25 21:13 Christian Grothoff Resolution open => fixed
2017-03-25 21:13 Christian Grothoff Fixed in Version => 0.11.0pre66
2017-03-25 21:13 Christian Grothoff Note Added: 0011976
2018-06-07 00:24 Christian Grothoff Status resolved => closed