View Issue Details

IDProjectCategoryView StatusLast Update
0004854GNUnetARM servicepublic2018-06-07 00:24
ReporterFlorian DoldAssigned ToChristian Grothoff 
PriorityhighSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0004854: gnunet-arm's -T option is broken
DescriptionThis used to work a while ago, but now when the ARM service isn't running, the gnunet-arm command hangs forever, despite passing "-T 5s"

We use this in the Taler deployment scripts, which now sometimes break/hang due to this bug.
Steps To Reproduce$ gnunet-arm -e -T1
Jan 12 14:11:43-664580 util-27249 WARNING Failed to establish connection to `arm', no further addresses to try.
TagsNo tags attached.

Activities

Christian Grothoff

2017-01-13 13:24

manager   ~0011628

Fixed in cdb7873..553da9b

Issue History

Date Modified Username Field Change
2017-01-12 14:14 Florian Dold New Issue
2017-01-12 14:14 Florian Dold Status new => assigned
2017-01-12 14:14 Florian Dold Assigned To => Christian Grothoff
2017-01-13 13:24 Christian Grothoff Status assigned => resolved
2017-01-13 13:24 Christian Grothoff Resolution open => fixed
2017-01-13 13:24 Christian Grothoff Fixed in Version => 0.11.0pre66
2017-01-13 13:24 Christian Grothoff Note Added: 0011628
2017-01-13 13:24 Christian Grothoff Product Version => SVN HEAD
2017-01-13 13:24 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:24 Christian Grothoff Status resolved => closed