View Issue Details

IDProjectCategoryView StatusLast Update
0004789Talerwallet (WebExtensions)public2016-11-20 03:26
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeveritytextReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.2Fixed in Version0.2 
Summary0004789: i18n missing for JSX literals
DescriptionJSX literals like this

  <i18n.Translate>
    Hello <span>{userName}</span>!
  </i18n.Translate>

  <i18n.TranslateSwitch target={number}>
    <i18n.TranslateSingular>You have <span>number</span> apple!</i18n.TranslateSingular>
    <i18n.TranslatePlural>You have <span>{number}</span> apples!</i18n.TranslatePlural>
  </i18n.TranslateSwitch>

should be picked up by pogen.
TagsNo tags attached.

Activities

Florian Dold

2016-11-17 02:10

manager   ~0011506

The extraction is now implemented.

The only thing that's missing is the integration with the Jed JS library to to the actual translation. This is kind of tricky, since with the JSX format, we get *either* the plural or the singular form, but by default Jed/gettext requires both for the lookup.

Florian Dold

2016-11-17 03:01

manager   ~0011507

Fixed in 4d7d1a1. The final syntax is updated in the description above.

Issue History

Date Modified Username Field Change
2016-11-15 13:59 Florian Dold New Issue
2016-11-15 13:59 Florian Dold Status new => assigned
2016-11-15 13:59 Florian Dold Assigned To => Florian Dold
2016-11-15 15:38 root Severity minor => text
2016-11-15 15:38 root Product Version => SVN HEAD
2016-11-15 15:38 root Target Version => 0.2
2016-11-17 02:08 Florian Dold Description Updated View Revisions
2016-11-17 02:10 Florian Dold Note Added: 0011506
2016-11-17 03:01 Florian Dold Note Added: 0011507
2016-11-17 03:01 Florian Dold Status assigned => resolved
2016-11-17 03:01 Florian Dold Resolution open => fixed
2016-11-19 01:45 Christian Grothoff Fixed in Version => 0.2
2016-11-20 03:26 Christian Grothoff Status resolved => closed