View Issue Details

IDProjectCategoryView StatusLast Update
0004765Talerwallet (WebExtensions)public2017-06-06 14:18
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeveritytextReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.3Fixed in Version0.3 
Summary0004765: documentation for test harnesses missing
DescriptionThere should be documentation for
- how to write a new test case
- how to run test cases in the browser
- how to run test cases from node
TagsNo tags attached.

Activities

Florian Dold

2017-05-28 22:44

manager   ~0012174

This now became trivial. We use AVA (https://github.com/avajs/ava) for testing. Tests are run by "make check". All "*-test.{ts,tsx}" files are considered unit tests.

We don't run tests inside the browser anymore, only for end-to-end tests we use selenium. This is common practice, since running things inside the browser is very slow and memory intensive, and the mocks available for NodeJS are good enough to catch errors.

Issue History

Date Modified Username Field Change
2016-11-08 15:03 Florian Dold New Issue
2016-11-08 15:03 Florian Dold Status new => assigned
2016-11-08 15:03 Florian Dold Assigned To => Florian Dold
2016-11-15 15:53 Christian Grothoff Severity minor => text
2016-11-15 15:53 Christian Grothoff Product Version => SVN HEAD
2016-11-15 15:53 Christian Grothoff Target Version => 0.3
2017-04-09 00:25 Christian Grothoff Target Version 0.3 => 0.6
2017-05-28 22:44 Florian Dold Status assigned => resolved
2017-05-28 22:44 Florian Dold Resolution open => fixed
2017-05-28 22:44 Florian Dold Note Added: 0012174
2017-05-28 22:53 Christian Grothoff Fixed in Version => 0.3
2017-05-28 22:53 Christian Grothoff Target Version 0.6 => 0.3
2017-06-06 14:18 Christian Grothoff Status resolved => closed