View Issue Details

IDProjectCategoryView StatusLast Update
0004715Talerwallet (WebExtensions)public2016-11-20 03:26
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.2Fixed in Version0.2 
Summary0004715: fix presence detection with disabled JavaScript in chromium
DescriptionApparently there is a bug in Chromium where window.setTimeout doesn't work when JavaScript is disabled in the browser settings.

Using NoScript should still work, since that just blocks JavaScript on the page.
TagsNo tags attached.

Relationships

duplicate of 0004807 closedFlorian Dold No wallet detected with JS disabled 

Activities

Florian Dold

2016-10-10 16:13

manager   ~0011285

Note that the normal payment still works, i.e. event handling is working, only timeouts aren't.

Christian Grothoff

2016-11-19 18:12

manager   ~0011537

Marcello reports that the landing page's presence detection does not work without JavaScript. Is this related?

Florian Dold

2016-11-19 18:18

manager   ~0011538

Yeah, this is the exact same problem. As long as the JavaScript is disable via content settings in Chrome (and not via a noscript extension), presence detection is broken!

Florian Dold

2016-11-19 23:28

manager   ~0011539

Fixed in 7b1511a243a

Issue History

Date Modified Username Field Change
2016-10-10 16:06 Florian Dold New Issue
2016-10-10 16:06 Florian Dold Status new => assigned
2016-10-10 16:06 Florian Dold Assigned To => Florian Dold
2016-10-10 16:13 Florian Dold Note Added: 0011285
2016-11-15 15:57 Christian Grothoff Severity minor => tweak
2016-11-15 15:57 Christian Grothoff Product Version => SVN HEAD
2016-11-19 17:50 Florian Dold Relationship added duplicate of 0004807
2016-11-19 18:12 Christian Grothoff Note Added: 0011537
2016-11-19 18:12 Christian Grothoff Target Version => 0.2
2016-11-19 18:18 Florian Dold Note Added: 0011538
2016-11-19 19:59 Christian Grothoff Target Version 0.2 =>
2016-11-19 23:28 Florian Dold Status assigned => resolved
2016-11-19 23:28 Florian Dold Resolution open => fixed
2016-11-19 23:28 Florian Dold Note Added: 0011539
2016-11-20 03:25 Christian Grothoff Fixed in Version => 0.2
2016-11-20 03:26 Christian Grothoff Target Version => 0.2
2016-11-20 03:26 Christian Grothoff Status resolved => closed