View Issue Details

IDProjectCategoryView StatusLast Update
0004695Talerwallet (WebExtensions)public2016-10-11 17:28
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.0 
Target Version0.1Fixed in Version0.1 
Summary0004695: the emscripten interface is not robust w.r.t. utf-8
DescriptionWe're using str.length to count the number of bytes, but since JavaScript strings are UTF16 arrays, this doesn't always give the right result.

Consequently, the wallet will truncate unicode strings in certain cases.
TagsNo tags attached.

Activities

Florian Dold

2016-09-28 23:41

manager   ~0011196

Fixed in 274204c

Issue History

Date Modified Username Field Change
2016-09-28 22:38 Florian Dold New Issue
2016-09-28 22:38 Florian Dold Status new => assigned
2016-09-28 22:38 Florian Dold Assigned To => Florian Dold
2016-09-28 23:41 Florian Dold Note Added: 0011196
2016-09-28 23:42 Florian Dold Status assigned => resolved
2016-09-28 23:42 Florian Dold Resolution open => fixed
2016-10-07 00:28 Christian Grothoff Product Version => 0.0
2016-10-07 00:28 Christian Grothoff Fixed in Version => 0.1
2016-10-07 00:28 Christian Grothoff Target Version => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed