View Issue Details

IDProjectCategoryView StatusLast Update
0004623GNUnetutil librarypublic2019-06-22 23:32
ReporterlynXAssigned Toxrs 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.6Fixed in VersionSVN HEAD 
Summary0004623: UX: getopt should complain if -v is used with other parameters
DescriptionYou can require the user to understand why the version string is output,
or you can help them by telling them that the version string may only be
requested when there are no further parameters (which imply that the
user didn't actually intend to ask for a version string). Possibly this
kind of UX refinement is applicable to other parameters.

Also, is it normal that outputting a version string produces an error
return code? GNU tools usually do not.
Steps To Reproducegnunet-namestore -L DEBUG -z master-zone -ap -t vpn -e "2 hours" -n telnet -v "6 TVV54YYR29KRDKM30ZC3014JXHDGPVT7KFQGA44CEV2YQSEVFDAG telnet"
gnunet-namestore v0.10.1 svn-r37587
Makefile:142: recipe for target 'names' failed

The -v should have been -V to function, but a clearer error message would
have spared some time figuring out what was going on.
Additional InformationFork of 0004616
TagsNo tags attached.

Activities

lynX

2016-08-29 08:34

developer   ~0011072

The reason why I didn't just fix it is because when I looked over the code I realized it is all but trivial to make this change without a profound understanding of it. So if I was the right person to deal with this problem, I wouldn't have written this bug report.

Christian Grothoff

2016-08-29 10:16

manager   ~0011074

I suspect what's tripping you up here is 'getopt.c', which is actually GNU getopt from the copylib. I don't have any more profound understanding of the getopt.c file than you do, but that one should not be changed anyway, except for the last function in the file: that's the GNUnet-specific code. And of course you can change getopt_helpers.c.

dvn

2019-01-28 04:46

developer   ~0013488

This surely is a UX bug, at least. lynX any feedback to comment 0004623:0011074 ?

NOTE: I don't think this is a blocker for the 0.11.0 release, so I'm going to untag it.

Christian Grothoff

2019-01-28 05:59

manager   ~0013492

I disagree, it caused some serious confusion for lynx before, which is why he filed it. It also makes a nice exercise for beginners...

xrs

2019-06-22 23:32

reporter   ~0014569

Resolved by 988ac7f121b646cba3ca44567f54b1315398505d.

Issue History

Date Modified Username Field Change
2016-08-23 08:54 lynX New Issue
2016-08-27 11:41 Christian Grothoff Assigned To => lynX
2016-08-27 11:41 Christian Grothoff Status new => assigned
2016-08-29 08:34 lynX Note Added: 0011072
2016-08-29 08:34 lynX Assigned To lynX => Christian Grothoff
2016-08-29 10:16 Christian Grothoff Note Added: 0011074
2016-08-30 13:19 Christian Grothoff Assigned To Christian Grothoff =>
2016-08-30 13:19 Christian Grothoff Status assigned => confirmed
2016-09-22 20:10 Christian Grothoff Target Version => 0.11.0pre66
2017-02-21 18:38 Christian Grothoff Target Version 0.11.0pre66 => 0.11.0
2017-02-26 02:26 Christian Grothoff Severity minor => feature
2018-06-27 00:02 Christian Grothoff Assigned To => Feideus
2018-06-27 00:02 Christian Grothoff Status confirmed => assigned
2019-01-27 11:59 Christian Grothoff Assigned To Feideus =>
2019-01-27 11:59 Christian Grothoff Status assigned => confirmed
2019-01-28 04:46 dvn Note Added: 0013488
2019-01-28 04:47 dvn Severity feature => tweak
2019-01-28 04:47 dvn Target Version 0.11.0 =>
2019-01-28 05:59 Christian Grothoff Note Added: 0013492
2019-06-05 19:02 Christian Grothoff Target Version => 0.11.6
2019-06-21 22:51 Christian Grothoff Assigned To => t3sserakt
2019-06-21 22:51 Christian Grothoff Status confirmed => assigned
2019-06-21 22:51 Christian Grothoff Assigned To t3sserakt => xrs
2019-06-22 23:32 xrs Status assigned => resolved
2019-06-22 23:32 xrs Resolution open => fixed
2019-06-22 23:32 xrs Fixed in Version => SVN HEAD
2019-06-22 23:32 xrs Note Added: 0014569