View Issue Details

IDProjectCategoryView StatusLast Update
0004608gnunet-gtkgnunet-peerinfo-gtkpublic2018-06-07 00:24
ReporterellAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionfixed 
PlatformDebian GNU/Linux 8.5 (jessie)OSamd64OS Version
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0004608: Failed at: information about known and connected peers
Descriptionell@DebianGTK3:~/gnunet-gtk$ gnunet-gtk
Aug 03 06:43:16-422243 gnunet-peerinfo-gtk-13903 ERROR Failed to load `/usr/local/share/gnunet/gnunet_peerinfo_gtk_main_window.glade': /usr/local/share/gnunet/gnunet_peerinfo_gtk_main_window.glade:260:51 Unsupported tag for GtkCellLayout: <property>

(gnunet-identity-gtk:13906): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(gnunet-conversation-gtk:13907): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

(gnunet-namestore-gtk:13904): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications.

(gnunet-fs-gtk:13905): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -9 and height -9
Aug 03 06:43:19-429039 gnunet-fs-gtk-13905 ERROR Assertion failed at fs_search.c:1148.
Additional Information/usr/local/share/gnunet$ls -la
insgesamt 2840
drwxr-sr-x 6 root staff 4096 Aug 3 06:41 .
drwxrwsr-x 26 root staff 4096 Nov 13 2015 ..
-rw-r--r-- 1 root staff 305 Aug 2 14:16 black.png
-rw-r--r-- 1 root staff 806 Aug 2 14:16 blue.png
drwxr-sr-x 2 root staff 4096 Aug 3 06:42 config.d
-rw-r--r-- 1 root staff 5120 Aug 2 14:16 conversation.png
-rw-r--r-- 1 root staff 5120 Aug 2 14:16 conversation_small.png
-rw-r--r-- 1 root staff 9356 Aug 2 14:16 conversation.svg
-rw-r--r-- 1 root staff 1718 Aug 2 14:16 downloaded.gif
-rw-r--r-- 1 root staff 1007 Aug 2 14:16 downloading.gif
-rw-r--r-- 1 root staff 1238 Aug 2 14:16 downloading_not_receiving.gif
-rw-r--r-- 1 root staff 9078 Aug 2 14:16 error.gif
drwxr-sr-x 2 root staff 4096 Aug 2 14:16 flags
-rw-r--r-- 1 root staff 1178 Aug 2 14:16 found_source.gif
-rw-r--r-- 1 root staff 3119 Aug 2 14:16 fs.png
-rw-r--r-- 1 root staff 3119 Aug 2 14:16 fs_small.png
-rw-r--r-- 1 root staff 16619 Aug 2 14:16 fs.svg
-rw-r--r-- 1 root staff 105182 Aug 3 06:41 gns-bcd.html
-rw-r--r-- 1 root staff 594739 Aug 3 06:41 gns-bcd.tex
-rw-r--r-- 1 root staff 1556 Aug 2 14:16 gns.png
-rw-r--r-- 1 root staff 1556 Aug 2 14:16 gns_small.png
-rw-r--r-- 1 root staff 6389 Aug 2 14:16 gns.svg
-rw-r--r-- 1 root staff 16488 Aug 2 14:16 gnunet_conversation_gtk_about_window.glade
-rw-r--r-- 1 root staff 5733 Aug 2 14:16 gnunet_conversation_gtk_enter_label.glade
-rw-r--r-- 1 root staff 72768 Aug 2 14:16 gnunet_conversation_gtk_main_window.glade
-rw-r--r-- 1 root staff 16485 Aug 2 14:16 gnunet_fs_gtk_about_window.glade
-rw-r--r-- 1 root staff 7367 Aug 2 14:16 gnunet_fs_gtk_download_as_dialog.glade
-rw-r--r-- 1 root staff 54435 Aug 2 14:16 gnunet_fs_gtk_edit_publication.glade
-rw-r--r-- 1 root staff 6119 Aug 2 14:16 gnunet_fs_gtk_enter_nick_dialog.glade
-rw-r--r-- 1 root staff 78310 Aug 2 14:16 gnunet_fs_gtk_main_window.glade
-rw-r--r-- 1 root staff 3461 Aug 2 14:16 gnunet_fs_gtk_open_directory_dialog.glade
-rw-r--r-- 1 root staff 10210 Aug 2 14:16 gnunet_fs_gtk_open_url_dialog.glade
-rw-r--r-- 1 root staff 6473 Aug 2 14:16 gnunet_fs_gtk_progress_dialog.glade
-rw-r--r-- 1 root staff 3646 Aug 2 14:16 gnunet_fs_gtk_pseu_progress_dialog.glade
-rw-r--r-- 1 root staff 49012 Aug 2 14:16 gnunet_fs_gtk_publish_dialog.glade
-rw-r--r-- 1 root staff 11683 Aug 2 14:16 gnunet_fs_gtk_publish_directory_dialog.glade
-rw-r--r-- 1 root staff 13137 Aug 2 14:16 gnunet_fs_gtk_publish_file_dialog.glade
-rw-r--r-- 1 root staff 6284 Aug 2 14:16 gnunet_fs_gtk_publish_tab.glade
-rw-r--r-- 1 root staff 14621 Aug 2 14:16 gnunet_fs_gtk_search_tab.glade
-rw-r--r-- 1 root staff 8130 Aug 2 14:16 gnunet_fs_gtk_unindex.glade
-rw-r--r-- 1 root staff 11769 Aug 2 14:16 gnunet_gtk.glade
-rw-r--r-- 1 root staff 971 Aug 2 14:16 gnunet_gtk_status_bar_menu.glade
-rw-r--r-- 1 root staff 16488 Aug 2 14:16 gnunet_identity_gtk_about_window.glade
-rw-r--r-- 1 root staff 34645 Aug 2 14:16 gnunet_identity_gtk_advertise_dialog.glade
-rw-r--r-- 1 root staff 8315 Aug 2 14:16 gnunet_identity_gtk_main_window.glade
-rw-r--r-- 1 root staff 6851 Aug 3 06:41 gnunet-logo-color.png
-rw-r--r-- 1 root staff 91138 Aug 3 06:41 gnunet-logo.pdf
-rw-r--r-- 1 root staff 33296 Aug 2 14:16 gnunet_namestore_edit_aaaa.glade
-rw-r--r-- 1 root staff 33296 Aug 2 14:16 gnunet_namestore_edit_a.glade
-rw-r--r-- 1 root staff 84906 Aug 2 14:16 gnunet_namestore_edit_box.glade
-rw-r--r-- 1 root staff 41803 Aug 2 14:16 gnunet_namestore_edit_cert.glade
-rw-r--r-- 1 root staff 33725 Aug 2 14:16 gnunet_namestore_edit_cname.glade
-rw-r--r-- 1 root staff 36502 Aug 2 14:16 gnunet_namestore_edit_gns2dns.glade
-rw-r--r-- 1 root staff 33292 Aug 2 14:16 gnunet_namestore_edit_leho.glade
-rw-r--r-- 1 root staff 35250 Aug 2 14:16 gnunet_namestore_edit_mx.glade
-rw-r--r-- 1 root staff 36075 Aug 2 14:16 gnunet_namestore_edit_phone.glade
-rw-r--r-- 1 root staff 33264 Aug 2 14:16 gnunet_namestore_edit_pkey.glade
-rw-r--r-- 1 root staff 33307 Aug 2 14:16 gnunet_namestore_edit_ptr.glade
-rw-r--r-- 1 root staff 46283 Aug 2 14:16 gnunet_namestore_edit_soa.glade
-rw-r--r-- 1 root staff 53726 Aug 2 14:16 gnunet_namestore_edit_srv.glade
-rw-r--r-- 1 root staff 72138 Aug 2 14:16 gnunet_namestore_edit_tlsa.glade
-rw-r--r-- 1 root staff 33236 Aug 2 14:16 gnunet_namestore_edit_txt.glade
-rw-r--r-- 1 root staff 39325 Aug 2 14:16 gnunet_namestore_edit_vpn.glade
-rw-r--r-- 1 root staff 25176 Aug 2 14:16 gnunet_namestore_gtk_main_window.glade
-rw-r--r-- 1 root staff 3568 Aug 2 14:16 gnunet_namestore_gtk_qr_save_as_dialog.glade
-rw-r--r-- 1 root staff 16488 Aug 2 14:16 gnunet_peerinfo_gtk_about_window.glade
-rw-r--r-- 1 root staff 20909 Aug 2 14:16 gnunet_peerinfo_gtk_main_window.glade
-rw-r--r-- 1 root staff 3840 Aug 2 14:16 gnunet_setup_calendar_dialog.glade
-rw-r--r-- 1 root staff 377077 Aug 2 14:16 gnunet_setup_main_window.glade
-rw-r--r-- 1 root staff 1468 Aug 2 14:16 gnunet-setup-oxygen-cancel.png
-rw-r--r-- 1 root staff 1218 Aug 2 14:16 gnunet-setup-oxygen-ok.png
-rw-r--r-- 1 root staff 16490 Aug 2 14:16 gnunet_statistics_gtk_about_window.glade
-rw-r--r-- 1 root staff 6484 Aug 2 14:16 gnunet_statistics_gtk_main_window.glade
-rw-r--r-- 1 root staff 822 Aug 2 14:16 green.png
drwxr-sr-x 2 root staff 4096 Aug 3 06:41 hellos
-rw-r--r-- 1 root staff 4612 Aug 2 14:16 identity.png
-rw-r--r-- 1 root staff 4612 Aug 2 14:16 identity_small.png
-rw-r--r-- 1 root staff 12169 Aug 2 14:16 identity.svg
-rw-r--r-- 1 root staff 2820 Aug 2 14:16 peerinfo.png
-rw-r--r-- 1 root staff 2820 Aug 2 14:16 peerinfo_small.png
-rw-r--r-- 1 root staff 9744 Aug 2 14:16 peerinfo.svg
-rw-r--r-- 1 root staff 1772 Aug 2 14:16 published.gif
-rw-r--r-- 1 root staff 1001 Aug 2 14:16 publishing.gif
-rw-r--r-- 1 root staff 793 Aug 2 14:16 purple.png
-rw-r--r-- 1 root staff 239 Aug 2 14:16 qr_dummy.png
-rw-r--r-- 1 root staff 813 Aug 2 14:16 red.png
-rw-r--r-- 1 root staff 1160 Aug 2 14:16 searching_sources.gif
drwxr-sr-x 4 root staff 4096 Nov 13 2015 sensors
-rw-r--r-- 1 root staff 3530 Aug 2 14:16 setup.png
-rw-r--r-- 1 root staff 1591 Aug 2 14:16 setup_small.png
-rw-r--r-- 1 root staff 6442 Aug 2 14:16 setup.svg
-rw-r--r-- 1 root staff 1640 Aug 2 14:16 statistics.png
-rw-r--r-- 1 root staff 1640 Aug 2 14:16 statistics_small.png
-rw-r--r-- 1 root staff 3961 Aug 2 14:16 statistics.svg
-rw-r--r-- 1 root staff 131072 Aug 3 06:41 testing_hostkeys.ecc
-rw-r--r-- 1 root staff 816 Aug 2 14:16 yellow.png
TagsNo tags attached.

Activities

Christian Grothoff

2017-02-26 01:31

manager   ~0011845

Looked into it, the file that is referenced in the report does no longer have the line that failed to parse at all in it, so that part has to be fixed. Added a note on the fs_search.c assertion failure, but that one is very odd. Also, I cannot reproduce it.

Christian Grothoff

2017-03-09 19:30

manager   ~0011916

Just reproduced this myself.

Christian Grothoff

2017-03-09 21:39

manager   ~0011917

Fixed in 20906d422..6037291cd

Issue History

Date Modified Username Field Change
2016-08-03 07:12 ell New Issue
2016-08-03 11:46 Christian Grothoff Assigned To => Christian Grothoff
2016-08-03 11:46 Christian Grothoff Status new => assigned
2016-09-22 20:11 Christian Grothoff Product Version => SVN HEAD
2016-09-22 20:11 Christian Grothoff Target Version => 0.11.0pre66
2017-02-26 01:31 Christian Grothoff Reproducibility always => unable to reproduce
2017-02-26 01:31 Christian Grothoff Status assigned => resolved
2017-02-26 01:31 Christian Grothoff Fixed in Version => 0.11.0pre66
2017-02-26 01:31 Christian Grothoff Note Added: 0011845
2017-03-09 19:30 Christian Grothoff Status resolved => assigned
2017-03-09 19:30 Christian Grothoff Note Added: 0011916
2017-03-09 21:39 Christian Grothoff Note Added: 0011917
2017-03-09 21:39 Christian Grothoff Status assigned => resolved
2017-03-09 21:39 Christian Grothoff Resolution open => fixed
2017-03-09 21:39 Christian Grothoff Reproducibility unable to reproduce => random
2018-06-07 00:24 Christian Grothoff Status resolved => closed