View Issue Details

IDProjectCategoryView StatusLast Update
0004562Talerdeployment and operationspublic2016-10-11 17:28
ReporterTorsten GrothoffAssigned ToFlorian Dold 
PriorityimmediateSeverityblockReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.0 
Target Version0.1Fixed in Version0.1 
Summary0004562: error 502
Descriptionween paying on blog!!
TagsNo tags attached.

Activities

Florian Dold

2016-06-06 20:19

manager   ~0010867

Erm ... looking at the logs, it means that we didn't update demo.taler.net to use the new crypto (Jeffs changes) before releasing 0.0.0.

D'oh. I'm fixing this now.

We have to get our monitoring in check. It took us days (!) to notice this issue, when we should have received an email after, like, a minute of it not working with the web store wallet.

Christian Grothoff

2016-06-07 00:34

manager   ~0010868

Same step also fails for blog.test.taler.net, except with a 400.

Florian Dold

2016-06-07 00:38

manager   ~0010869

I can't reproduce that, are you using the latest wallet (0.0.0) and have you tried resetting it? The DB schema changed recently, but there should be an alert for this when the extension is loaded.

Florian Dold

2016-06-07 00:39

manager   ~0010870

I also can't find anything relevant in the logs, but that might just indicate that our logging is bad ;-)

Florian Dold

2016-06-07 00:48

manager   ~0010871

07/Jun/2016:00:33:51 +0200 HTTP/1.1 POST /pay?uuid=AM2D42EXRREJ8VR67KTFCWTQ7525TTG0SX2NVH93YVZHD5XY8GHWGTBFKDVEVY1YYWZQ989MHM26CA1YJS5GWNFJ0MW7AQKZQ30R630 HTTP/1.1 => 400

That probably was your request. No other useful information though, the blog merchant should do more logging I guess.

I still can't reproduce the issue with my wallet though.

Christian Grothoff

2016-06-07 08:09

manager   ~0010872

Yes, I had a pre-0.0.0 wallet on this system for the 400-error.

Florian Dold

2016-06-07 19:28

manager   ~0010877

Fixed in the demo deployment now.

Issue History

Date Modified Username Field Change
2016-06-06 19:37 Torsten Grothoff New Issue
2016-06-06 19:38 Christian Grothoff Assigned To => Florian Dold
2016-06-06 19:38 Christian Grothoff Status new => assigned
2016-06-06 19:38 Christian Grothoff Product Version => 0.0
2016-06-06 19:38 Christian Grothoff Target Version => 0.1
2016-06-06 20:19 Florian Dold Note Added: 0010867
2016-06-07 00:34 Christian Grothoff Note Added: 0010868
2016-06-07 00:38 Florian Dold Note Added: 0010869
2016-06-07 00:39 Florian Dold Note Added: 0010870
2016-06-07 00:48 Florian Dold Note Added: 0010871
2016-06-07 08:09 Christian Grothoff Note Added: 0010872
2016-06-07 19:28 Florian Dold Note Added: 0010877
2016-06-07 19:28 Florian Dold Status assigned => resolved
2016-06-07 19:28 Florian Dold Resolution open => fixed
2016-06-08 22:19 Christian Grothoff Fixed in Version => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed