View Issue Details

IDProjectCategoryView StatusLast Update
0004440GNUnetbuild processpublic2018-06-07 00:24
ReporterFlorian DoldAssigned Tong0 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0004440: ./bootstraps chokes with incomprehensible output if libtool is not installed
DescriptionWe should include a basic sanity check, so it's more obvious what the problem is.
Additional Informationpkgconfig/Makefile.am:53: warning: '%'-style pattern rules are a GNU make extension
src/arm/Makefile.am:95: warning: '%'-style pattern rules are a GNU make extension
src/arm/Makefile.am:20: error: Libtool library used but 'LIBTOOL' is undefined
src/arm/Makefile.am:20: The usual way to define 'LIBTOOL' is to add 'LT_INIT'
src/arm/Makefile.am:20: to 'configure.ac' and run 'aclocal' and 'autoconf' again.
src/arm/Makefile.am:20: If 'LT_INIT' is in 'configure.ac', make sure
src/arm/Makefile.am:20: its definition is in aclocal's search path.
src/ats-tests/Makefile.am:37: error: Libtool library used but 'LIBTOOL' is undefined
src/ats-tests/Makefile.am:37: The usual way to define 'LIBTOOL' is to add 'LT_INIT'
src/ats-tests/Makefile.am:37: to 'configure.ac' and run 'aclocal' and 'autoconf' again.
TagsNo tags attached.

Activities

ng0

2016-08-28 16:35

developer   ~0011069

I was able to reproduce this without the intention to do so - there really should be a check in place.

ng0

2017-10-16 23:23

developer   ~0012489

I went through a couple of possible solutions, the canonical one spits even more verbose messages. It has to be done in the 'bootstrap' shell script.
We need to check for libtool as well as libtoolize.

I'll attempt to fix this and a couple of other messages in our configure process this week (probably tomorrow).

ng0

2017-10-17 13:06

developer   ~0012490

{g}libtool{ize} problem fixed for me this way: https://gnunet.org/git/gnunet.git/commit/?id=6b2f72df1c7b7317c1c8c52efd74f40c9d30c28a

Workin on the rest of the messages now, when I no longer see messages of old autoconf / autotools suite I'll consider this bug resolved.

ng0

2017-10-17 14:40

developer   ~0012491

Fixed in https://gnunet.org/git/gnunet.git/commit/?id=4a3f7e1ce17b5109e713cdbb37ad85a8852d4723 and https://gnunet.org/git/gnunet.git/commit/?id=7348fad86391b913ecc41f986066f260efb04633

I will document the reasons behind this OR just the way to do it in documentation.

ng0

2017-10-17 14:41

developer   ~0012492

Two last warnings remain, I'll look into this. They are not related to the reported issue.

Issue History

Date Modified Username Field Change
2016-04-18 18:45 Florian Dold New Issue
2016-08-28 16:35 ng0 Note Added: 0011069
2017-02-26 01:43 Christian Grothoff Severity minor => tweak
2017-10-16 23:23 ng0 Note Added: 0012489
2017-10-16 23:23 ng0 Assigned To => ng0
2017-10-16 23:23 ng0 Status new => assigned
2017-10-16 23:25 ng0 Reproducibility have not tried => always
2017-10-17 13:06 ng0 Note Added: 0012490
2017-10-17 14:40 ng0 Note Added: 0012491
2017-10-17 14:41 ng0 Note Added: 0012492
2017-10-17 14:42 ng0 Status assigned => resolved
2017-10-17 14:42 ng0 Resolution open => fixed
2017-10-17 14:42 ng0 Fixed in Version => SVN HEAD
2018-06-05 22:26 Christian Grothoff Product Version => SVN HEAD
2018-06-05 22:26 Christian Grothoff Fixed in Version SVN HEAD => 0.11.0pre66
2018-06-05 22:26 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:24 Christian Grothoff Status resolved => closed