View Issue Details

IDProjectCategoryView StatusLast Update
0004232TalerWeb site(s)public2016-10-11 17:28
ReporterChristian GrothoffAssigned Totg 
PriorityhighSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Version0.0 
Target Version0.1Fixed in Version0.1 
Summary0004232: chrome version not detected before suggesting Taler plugin installation
DescriptionRight now, we suggest to all visitors of the page that they should click to install the extension. We should

1) detect if they actually use chrome/chromium or a compatible browser, and if not inform them that their platform is not yet supported;

2) detect if the version of chrome/chromium they have is sufficiently recent. I had someone try it, just to despair in the Google App store because the "install" button didn't show. The reason was (presumably) that their Chrome version was ancient, and then the app store detected the incompatibility. We should try to detect this issue earlier and warn the user as in case (1).

TagsNo tags attached.

Activities

tg

2016-08-03 16:42

developer   ~0011003

manifest.json already contains
  "minimum_chrome_version": "47.0.2526"

if this is incorrect, it should be fixed there.

on https://taler.net/wallet-installation.html
installWallet() also refers to the webstore,
that's where the version check takes place.

Christian Grothoff

2016-08-03 20:54

manager   ~0011004

I suspect maybe old Chrome versions don't enforce this manifest-check? Regardless, the point of this bug was to do the check in the JS of the landing page and to tell users there that they need a more recent browser.

tg

2016-08-17 12:05

developer   ~0011040

fixed in 15cb970

Issue History

Date Modified Username Field Change
2016-03-02 21:26 Christian Grothoff New Issue
2016-03-02 21:26 Christian Grothoff Status new => assigned
2016-03-02 21:26 Christian Grothoff Assigned To => tg
2016-03-20 21:53 Torsten Grothoff Issue cloned: 0004270
2016-08-03 16:42 tg Note Added: 0011003
2016-08-03 20:54 Christian Grothoff Note Added: 0011004
2016-08-17 12:05 tg Note Added: 0011040
2016-08-17 12:05 tg Status assigned => resolved
2016-08-17 12:05 tg Resolution open => fixed
2016-08-17 12:05 tg Fixed in Version => SVN HEAD
2016-09-19 00:55 Christian Grothoff Fixed in Version SVN HEAD => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed