View Issue Details

IDProjectCategoryView StatusLast Update
0004200Talerwallet (WebExtensions)public2016-10-11 17:28
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.1Fixed in Version0.1 
Summary0004200: use async syntax for promises as soon as available in tsc
DescriptionThe async syntax support for the ES5 target should land in the TypeScript compiler in a few weeks.

We should use this as soon as it's available, since it would make the wallet code a lot more readable (no more .then() nesting from hell ...).
TagsNo tags attached.

Activities

Florian Dold

2016-02-22 19:24

manager   ~0010168

Note that our target browsers already support native async (http://caniuse.com/#search=async), but due to a tsc bug (https://github.com/Microsoft/TypeScript/issues/6426) we currently compile down to ES5.

Florian Dold

2016-09-28 19:09

manager   ~0011192

Fixed in db9b98b

Issue History

Date Modified Username Field Change
2016-02-22 19:12 Florian Dold New Issue
2016-02-22 19:12 Florian Dold Status new => assigned
2016-02-22 19:12 Florian Dold Assigned To => Florian Dold
2016-02-22 19:24 Florian Dold Note Added: 0010168
2016-02-28 17:27 Christian Grothoff Severity minor => tweak
2016-03-20 21:53 Torsten Grothoff Issue cloned: 0004276
2016-09-28 19:09 Florian Dold Note Added: 0011192
2016-09-28 19:09 Florian Dold Status assigned => resolved
2016-09-28 19:09 Florian Dold Resolution open => fixed
2016-09-28 23:30 Christian Grothoff Fixed in Version => 0.1
2016-10-11 17:25 Christian Grothoff Product Version => SVN HEAD
2016-10-11 17:25 Christian Grothoff Target Version => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed