View Issue Details

IDProjectCategoryView StatusLast Update
0004019GNUnetcore servicepublic2018-06-07 00:37
ReporterBart PolotAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0Fixed in Version0.11.0pre66 
Summary0004019: CORE compains about mixed identities
DescriptionCORE constantly compains about wrong PING/PONG identites:


Oct 22 21:42:56-850664 core-27362 ERROR Received PING from `BART' for different identity: I am `VYGR', PONG identity: `RTAQ'
Oct 22 21:42:56-850723 core-27362 WARNING External protocol violation detected at gnunet-service-core_kx.c:1077.

[0000178:0000200 repetitions]

Oct 22 22:01:34-875198 core-27362 ERROR Received PING from `BART' for different identity: I am `VYGR', PONG identity: `DZEN'
Oct 22 22:01:34-875309 core-27362 WARNING External protocol violation detected at gnunet-service-core_kx.c:1077.
Steps To ReproduceRun a peer in the public network.
TagsNo tags attached.

Relationships

related to 0003863 closedChristian Grothoff TRANSPORT (and indirectly CORE) takes unreasonably large amounts of time to call back. 

Activities

Christian Grothoff

2015-10-23 01:04

manager   ~0009775

I see it, but only with BART and KPNK. Do we know what those two may have in common?

Christian Grothoff

2015-10-26 16:21

manager   ~0009790

Now, I don't see this anymore. Odd.

Bart Polot

2015-10-26 20:24

reporter   ~0009798

BART is down, that's maybe why...

Christian Grothoff

2015-10-27 15:31

manager   ~0009810

Can you revive BART?

Christian Grothoff

2015-10-28 11:28

manager   ~0009812

Logging message changed in SVN 36609: now we log rekey operations (as they may explain the KX failure), and also only log the sender of the bogus PING, not the content which is irrelevant (as we failed to decrypt).

Christian Grothoff

2015-10-28 14:09

manager   ~0009820

Possibly related: I get these quite a lot, but only on pixel, not on gnunet9:

Oct 28 10:19:21-103776 core-26665 ERROR Received EPHEMERAL_KEY from KHP1, but expected JHM1013RVC1T0BTB5VM1VNFBV0EM00V264JRE8S09584H7GHT4SG
Oct 28 10:19:22-786130 core-26665 ERROR Received EPHEMERAL_KEY from KHP1, but expected JHM1013RVC1T0BTB5VM1VNFBV0EM00V264JRE8S09584H7GHT4SG
Oct 28 10:19:43-421441 core-26665 ERROR Received EPHEMERAL_KEY from KHP1, but expected JHM1013RVC1T0BTB5VM1VNFBV0EM00V264JRE8S09584H7GHT4SG
Oct 28 10:20:23-107805 core-26665 ERROR Received EPHEMERAL_KEY from KHP1, but expected JHM1013RVC1T0BTB5VM1VNFBV0EM00V264JRE8S09584H7GHT4SG
Oct 28 10:21:43-067558 core-26665 ERROR Received EPHEMERAL_KEY from KHP1, but expected JHM1013RVC1T0BTB5VM1VNFBV0EM00V264JRE8S09584H7GHT4SG
Oct 28 10:21:53-651507 core-26665 ERROR Received EPHEMERAL_KEY from 7SK8, but expected 7PJ8TAM7Q2EBSV0FT91RK1P1C2G5MRN3MVQ53HNHV9D45KGFV1DG
Oct 28 10:24:22-190294 core-26665 ERROR Received EPHEMERAL_KEY from KHP1, but expected JHM1013RVC1T0BTB5VM1VNFBV0EM00V264JRE8S09584H7GHT4SG
Oct 28 10:24:34-246332 core-26665 ERROR Received EPHEMERAL_KEY from XT25, but expected TQ2502VA31VBKRB2V09JSVRPAQH99GCHGGAMS3Q27692QM5E4VVG
Oct 28 10:24:44-415154 core-26665 ERROR Received EPHEMERAL_KEY from XT25, but expected TQ2502VA31VBKRB2V09JSVRPAQH99GCHGGAMS3Q27692QM5E4VVG
Oct 28 10:25:06-725381 core-26665 ERROR Received EPHEMERAL_KEY from XT25, but expected TQ2502VA31VBKRB2V09JSVRPAQH99GCHGGAMS3Q27692QM5E4VVG
Oct 28 10:25:44-594928 core-26665 ERROR Received EPHEMERAL_KEY from XT25, but expected TQ2502VA31VBKRB2V09JSVRPAQH99GCHGGAMS3Q27692QM5E4VVG
Oct 28 10:27:06-347836 core-26665 ERROR Received EPHEMERAL_KEY from XT25, but expected TQ2502VA31VBKRB2V09JSVRPAQH99GCHGGAMS3Q27692QM5E4VVG
Oct 28 10:29:43-123996 core-26665 ERROR Received EPHEMERAL_KEY from KHP1, but expected JHM1013RVC1T0BTB5VM1VNFBV0EM00V264JRE8S09584H7GHT4SG
Oct 28 10:29:45-420656 core-26665 ERROR Received EPHEMERAL_KEY from XT25, but expected TQ2502VA31VBKRB2V09JSVRPAQH99GCHGGAMS3Q27692QM5E4VVG
Oct 28 10:35:04-314103 core-26665 ERROR Received EPHEMERAL_KEY from XT25, but expected TQ2502VA31VBKRB2V09JSVRPAQH99GCHGGAMS3Q27692QM5E4VVG

Christian Grothoff

2015-10-29 11:01

manager   ~0009828

Logs suggest this may be related to rekeying. Updated log message generated for malformed PINGs to consider if we just rekeyed.

Christian Grothoff

2018-06-07 00:37

manager   ~0012987

I've seen exactly this happen if two peers share the same private key due to bad setup (i.e. copy of VM image). Hence declaring 'fixed'.

Issue History

Date Modified Username Field Change
2015-10-22 22:06 Bart Polot New Issue
2015-10-22 22:06 Bart Polot Status new => assigned
2015-10-22 22:06 Bart Polot Assigned To => Christian Grothoff
2015-10-22 22:06 Bart Polot Relationship added related to 0003863
2015-10-23 01:04 Christian Grothoff Note Added: 0009775
2015-10-26 11:37 Christian Grothoff Priority normal => high
2015-10-26 16:21 Christian Grothoff Note Added: 0009790
2015-10-26 20:24 Bart Polot Note Added: 0009798
2015-10-27 15:31 Christian Grothoff Note Added: 0009810
2015-10-28 11:28 Christian Grothoff Note Added: 0009812
2015-10-28 14:09 Christian Grothoff Note Added: 0009820
2015-10-29 11:01 Christian Grothoff Note Added: 0009828
2015-10-31 16:16 Christian Grothoff Priority high => normal
2015-10-31 16:16 Christian Grothoff Target Version 0.11.0pre66 => 0.11.0
2018-06-07 00:37 Christian Grothoff Status assigned => closed
2018-06-07 00:37 Christian Grothoff Resolution open => fixed
2018-06-07 00:37 Christian Grothoff Fixed in Version => 0.11.0pre66
2018-06-07 00:37 Christian Grothoff Note Added: 0012987