View Issue Details

IDProjectCategoryView StatusLast Update
0004009GNUnettransport servicepublic2018-06-07 00:35
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PriorityhighSeveritymajorReproducibilitysometimes
Status closedResolutionwon't fix 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.11.0Fixed in Version0.11.0pre66 
Summary0004009: bandwidth disagreement between ATS and transport lib
DescriptionI see peers with 1kb/s getting seriously throttled by transport lib, i.e.

Oct 17 03:55:06-994169 transport-api-23885 WARNING Added 13429 bytes of payload message for F279 after 13 s delay at 1024 b/s

while at the same time, ATS has assigned >100kb/s:

Peer `F279' plugin `udp', address `udp.0.123.31.16.5:2086', `WAN' bw out: 106659 Bytes/s, bw in 106659 Bytes/s, active

TagsNo tags attached.

Relationships

child of 0003863 closedChristian Grothoff TRANSPORT (and indirectly CORE) takes unreasonably large amounts of time to call back. 

Activities

Christian Grothoff

2015-10-17 19:52

manager   ~0009736

So far, I caught two places where we "ignore" the neighbour_receive_quota from the other peer upon first setting the primary address. This explains the quota being *too high*. (As the other peer may set a lower quota than what ATS demands).

Christian Grothoff

2015-10-17 21:03

manager   ~0009737

Inconsistent use of the inbound quota is fixed in 36518. 36518 also adds a #define to *disable* the use of the inbound quota entirely, to test if this addresses the latency issues that we observed.

Christian Grothoff

2015-10-29 14:18

manager   ~0009853

SVN 36622 reverts the #define to disable the inbound quota, as this issue should hopefully be resolved by now (or at least explained by low inbound quotas).

Christian Grothoff

2015-10-30 00:01

manager   ~0009859

Reopening: if I re-enable the inbound quota, various tests start to fail because the peers remain stuck at a quota of 1k/s. So there is probably something more significant going on. #define reverted to NO for now in SVN.

Christian Grothoff

2018-06-07 00:35

manager   ~0012985

Changing to won't fix, as ATS subsystem will need a major rewrite first anyway.

Issue History

Date Modified Username Field Change
2015-10-17 03:56 Christian Grothoff New Issue
2015-10-17 03:56 Christian Grothoff Status new => assigned
2015-10-17 03:56 Christian Grothoff Assigned To => Christian Grothoff
2015-10-17 03:57 Christian Grothoff Relationship added child of 0003863
2015-10-17 19:52 Christian Grothoff Note Added: 0009736
2015-10-17 21:03 Christian Grothoff Note Added: 0009737
2015-10-29 14:18 Christian Grothoff Note Added: 0009853
2015-10-29 14:18 Christian Grothoff Status assigned => resolved
2015-10-29 14:18 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-10-29 14:18 Christian Grothoff Resolution open => fixed
2015-10-30 00:01 Christian Grothoff Note Added: 0009859
2015-10-30 00:01 Christian Grothoff Status resolved => assigned
2015-10-30 00:33 Christian Grothoff Fixed in Version 0.11.0pre66 =>
2015-10-30 00:33 Christian Grothoff Priority normal => high
2015-11-21 06:11 amatus Resolution fixed => open
2017-02-26 01:25 Christian Grothoff Target Version 0.11.0pre66 => 0.11.0
2018-06-07 00:35 Christian Grothoff Status assigned => closed
2018-06-07 00:35 Christian Grothoff Resolution open => won't fix
2018-06-07 00:35 Christian Grothoff Fixed in Version => 0.11.0pre66
2018-06-07 00:35 Christian Grothoff Note Added: 0012985