View Issue Details

IDProjectCategoryView StatusLast Update
0003986GNUnetpeerinfo servicepublic2018-06-07 00:24
ReporterBart PolotAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003986: Peerinfo has ~ 1000 duplicate addresses
Description[bart@saturn ~]$ gnunet-peerinfo -n
[clip]
Peer `GN108TBT30PB350KHYNNTEPWGT7MZB78561QPA1XGHHKD8XQCA90'
        Expires: Sa Sep 19 15:30:38 2015 udp.0.216.139.213.94:2086
        Expires: Sa Sep 19 15:30:15 2015 tcp.0.216.139.213.94:2086

Peer `R47DHSEKARZF0P3M6FP4X5R76ZSA2AZH10MM15RY9BGPCY95ZSG0'
        Expires: Do Sep 17 21:21:57 2015 udp.0.[2001:470:6d:b92:21f:16ff:fe08:9585]:2086
        Expires: Mo Sep 14 10:46:05 2015 udp.0.[2001:470:6d:b92:11fc:cc33:f8f7:ecf9]:2086
        Expires: Mo Sep 14 01:07:15 2015 udp.0.[2001:470:6d:b92:dc4:5cf0:a405:7fde]:2086
        Expires: Sa Sep 12 22:30:24 2015 udp.0.[2001:470:6d:b92:3922:7782:c301:4876]:2086

Peer `STRNFWB1WMN3GWMNXS80W5NEDH2DK0JBCQB9VJSWK7W27F9NC2WG'
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
[clip]
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 tcp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 tcp.0.172.25.0.1:10003
        Expires: Sa Sep 19 15:26:44 2015 tcp.0.10.192.0.1:10003
        Expires: Sa Sep 19 15:26:44 2015 tcp.0.[2001:4ca0:2001:11:155c:20c0:8389:80ec]:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.172.25.0.1:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.10.192.0.1:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.[2001:4ca0:2001:11:155c:20c0:8389:80ec]:10003
        Expires: Sa Sep 19 15:26:44 2015 udp.0.131.159.20.59:10003

Peer `7SZ56SYPG5EGKSHS82MPX5Y1RGXR9G0VCCTZ3NQHCBQQ451KF8NG'
        Expires: Sa Sep 19 14:20:38 2015 udp.0.129.187.173.185:2086
        Expires: Sa Sep 19 14:07:18 2015 tcp.0.129.187.173.180:2086
        Expires: Sa Sep 19 14:04:36 2015 udp.0.129.187.173.180:2086

[bart@saturn ~]$ gnunet-peerinfo -n | grep udp.0.131.159.20.59:10003 | wc
   1073 7511 66526
TagsNo tags attached.

Relationships

has duplicate 0003911 closedBart Polot Peerinfo doesn't get the correct addresses. 

Activities

Christian Grothoff

2015-10-05 17:28

manager   ~0009695

They seem to be all for UDP and always for the local peer.

Looking through the code, this could be explained by the local peer getting the same address many times from NAT, and never getting it 'removed'.

This happens specifically because the new STUN logic never removed addresses. Fixed in 36441.
I also added some logic to ensure de-duplication when transport combines the addresses in SVN 36441.

Christian Grothoff

2015-10-05 17:28

manager   ~0009696

Note that you may have to delete the respective HELLO file from disk to see the fix working.

Issue History

Date Modified Username Field Change
2015-09-19 03:37 Bart Polot New Issue
2015-09-19 03:38 Bart Polot Summary Peerinfo has 0000546:0001000 duplicate addresses => Peerinfo has \0000546:0001000 duplicate addresses
2015-09-19 03:38 Bart Polot Summary Peerinfo has \0000546:0001000 duplicate addresses => Peerinfo has ~ 1000 duplicate addresses
2015-09-19 03:38 Bart Polot Relationship added related to 0003911
2015-10-02 16:55 Christian Grothoff Assigned To => Christian Grothoff
2015-10-02 16:55 Christian Grothoff Status new => assigned
2015-10-03 19:13 Bart Polot Relationship replaced has duplicate 0003911
2015-10-05 17:28 Christian Grothoff Note Added: 0009695
2015-10-05 17:28 Christian Grothoff Note Added: 0009696
2015-10-05 17:28 Christian Grothoff Status assigned => resolved
2015-10-05 17:28 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-10-05 17:28 Christian Grothoff Resolution open => fixed
2018-06-07 00:24 Christian Grothoff Status resolved => closed