View Issue Details

IDProjectCategoryView StatusLast Update
0003929GNUnetcadet servicepublic2018-06-07 00:24
ReporterChristian GrothoffAssigned ToBart Polot 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003929: cadet abort() in assertion failure
Description(gdb) ba
#0 0x00007f4bfaf05107 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1 0x00007f4bfaf064e8 in __GI_abort () at abort.c:89
#2 0x00007f4bfc3ca758 in GNUNET_abort_ () at common_logging.c:290
#3 0x000000000041533d in connection_poll (cls=0x1c0e520, tc=0x7fff1494f010) at gnunet-service-cadet_connection.c:1439
#4 0x00007f4bfc406fa7 in run_ready (rs=0x1be7c00, ws=0x1be7c90) at scheduler.c:587
#5 0x00007f4bfc40789b in GNUNET_SCHEDULER_run (task=0x7f4bfc4142a5 <service_task>, task_cls=0x7fff1494f3b0) at scheduler.c:868
#6 0x00007f4bfc415fb7 in GNUNET_SERVICE_run (argc=3, argv=0x7fff1494f648, service_name=0x43b1aa "cadet",
    options=GNUNET_SERVICE_OPTION_NONE, task=0x433e55 <run>, task_cls=0x0) at service.c:1503
#7 0x00000000004341c4 in main (argc=3, argv=0x7fff1494f648) at gnunet-service-cadet.c:174
Steps To ReproduceFrom gnunet9-peer, running ~SVN 36200.
TagsNo tags attached.

Relationships

duplicate of 0003718 closedBart Polot GNUNET_assert (NULL != fc->poll_msg); failed in rev 35365 

Activities

Bart Polot

2015-09-03 20:05

manager   ~0009604

Fixed in r36310.

Issue History

Date Modified Username Field Change
2015-08-04 14:33 Christian Grothoff New Issue
2015-08-04 14:33 Christian Grothoff Status new => assigned
2015-08-04 14:33 Christian Grothoff Assigned To => Bart Polot
2015-08-05 17:48 amatus Relationship added duplicate of 0003718
2015-09-03 20:05 Bart Polot Note Added: 0009604
2015-09-03 20:05 Bart Polot Status assigned => resolved
2015-09-03 20:05 Bart Polot Fixed in Version => SVN HEAD
2015-09-03 20:05 Bart Polot Resolution open => fixed
2015-09-16 11:26 Christian Grothoff Fixed in Version SVN HEAD => 0.11.0pre66
2018-06-07 00:24 Christian Grothoff Status resolved => closed