View Issue Details

IDProjectCategoryView StatusLast Update
0003899GNUnettransport servicepublic2019-02-16 13:56
ReporteramatusAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0Fixed in Version0.11.0 
Summary0003899: transport validations seem to be stacking up
DescriptionAddress validation stats from my rev 36091 peer that's been running for about two days:

    transport # address revalidations started: 105964
    transport # validations running: 24183
    transport # validations succeeded: 10714
    transport # validations delayed by global throttle: 75948
Additional InformationFull transport stats:

    transport # UDP, total, bytes payload, sent: 354076325
    transport # UDP, total, bytes overhead, sent: 295030434
    transport # UDP, unfragmented msgs, bytes overhead, sent, success: 6970560
    transport # UDP, unfragmented msgs, bytes payload, sent, success: 29823794
    transport # UDP, unfragmented msgs, messages, sent, success: 174264
    transport # messages transmitted to other peers: 2397921
    transport # bytes in message queue for other peers: 1673780
    transport # UDP, total, messages, sent, success: 950570
    transport # UDP, total, bytes, sent, success: 672049923
    transport # UDP, total messages in send buffers: 0
    transport # UDP, total bytes in send buffers: 0
    transport # UDP, unfragmented bytes payload queued total: 29836800
    transport # UDP, unfragmented messages queued total: 174370
    transport # bytes payload received: 20290908906
    transport # bytes total received: 20306716963
    transport # bytes received via TCP: 17601052252
    transport # validations running: 24183
    transport # Addresses in validation map: 167
    transport # address records discarded (timeout): 70813
    transport # bytes transmitted via TCP: 13863504600
    transport # bytes currently in TCP buffers: 2682
    transport # ATS suggestions received: 2939780
    transport # bytes transmitted via https_server: 465347687
    transport # bytes currently in https_server buffers: 35275
    transport # SYN messages sent: 50845
    transport # blocked addresses: 24
    transport # Addresses given to ATS: 60
    transport # fragments received: 1235025
    transport # UDP, total bytes received: 1755292136
    transport # QUOTA messages received: 360387
    transport # HTTP client connections: 2
    transport # PINGs for address validation sent: 90439
    transport # bytes currently in http_client buffers: 22058953058426
    transport # address revalidations started: 105964
    transport # TCP sessions active: 55
    transport # TCP server connect events: 34786
    transport # TCP server connections active: 55
    transport # KEEPALIVE_RESPONSEs received (OK): 56299
    transport # validations delayed by global throttle: 75948
    transport # UDP sessions active: 31
    transport # PONGs unicast via reliable transport: 44639
    transport # successful address checks during validation: 44639
    transport # PING messages received: 44707
    transport # KEEPALIVES sent: 57642
    transport # KEEPALIVES received in good order: 92741
    transport # UDP, ACK messages sent: 327561
    transport # acknowledgements sent for fragment: 328553
    transport # duplicate fragments received: 233793
    transport # messages defragmented: 49670
    transport # UDP, fragmented msgs, bytes overhead, sent, success: 288059874
    transport # UDP, fragmented msgs, bytes payload, sent, success: 324252531
    transport # UDP, fragmented msgs, messages, sent, success: 11882
    transport # UDP, fragmented messages active: 0
    transport # fragmentation transmissions completed: 11882
    transport # fragment acknowledgements received: 29360
    transport # UDP, fragmented msgs, fragments bytes, sent, success: 616912153
    transport # UDP, fragmented msgs, fragments, sent, success: 448745
    transport # fragments wrap arounds: 30759
    transport # fragments retransmitted: 210872
    transport # fragments transmitted: 449662
    transport # UDP, fragmented bytes (payload): 324884530
    transport # UDP, fragmented messages, total: 11906
    transport # total size of fragmented messages: 325360770
    transport # messages fragmented: 11906
    transport # REQUEST CONNECT messages received: 168792
    transport # bytes discarded by TCP (disconnect): 9481827
    transport # network-level TCP disconnect events: 32424
    transport # bytes received via http_server: 268873943
    transport # Successful attempts to switch addresses: 635
    transport # SYN_ACK messages received: 4574
    transport # Attempts to switch addresses: 822
    transport # TCP WELCOME messages received: 3392
    transport # validations succeeded: 10714
    transport # PONG messages received: 10716
    transport # HTTPS client connections: 0
    transport # bytes currently in https_client buffers: 17416093626755
    transport # Multicast HELLO beacons received via UDP: 5290
    transport # bytes received via https_server: 647129454
    transport # bytes transmitted via http_server: 61279718
    transport # bytes currently in http_server buffers: 125613
    transport # SYN messages received: 13949
    transport # ATS suggestions ignored (failed to create session): 195
    transport # KEEPALIVE_RESPONSEs discarded (not expected): 253
    transport # transmission failures for messages to other peers: 270
    transport # peers connected: 43
    transport # DISCONNECT messages sent: 381
    transport # refreshed my HELLO: 3021
    transport # transport addresses: 4
    transport # ACK messages received: 1966
    transport # SYN_ACK messages sent: 3537
    transport # messages discarded due to timeout: 104
    transport # UDP, unfragmented msgs, bytes overhead, sent, failure: 4240
    transport # UDP, unfragmented msgs, bytes payload, sent, failure: 13006
    transport # UDP, unfragmented msgs, messages, sent, failure: 106
    transport # UDP, fragments discarded without ACK: 992
    transport # DISCONNECT messages received: 226
    transport # KEEPALIVE_RESPONSEs discarded (bad nonce): 42
    transport # disconnected from peer upon explicit request: 463
    transport # bytes payload discarded due to not connected peer: 3254209
    transport # ATS suggestion ignored (disconnecting): 1
    transport # UDP, fragmented msgs, bytes payload, sent, failure: 8967065
    transport # UDP, fragmented msgs, messages, sent, failure: 24
    transport # unexpected ACK messages: 21
    transport # disconnect messages ignored (timestamp): 6
    transport # bytes discarded by TCP (timeout): 4178
    transport # unexpected SYN_ACK messages (no peer): 6
    transport # ms throttling suggested: 825160
    transport # KEEPALIVE_RESPONSEs discarded (no nonce): 11
    transport # Failed attempts to switch addresses (failed to send SYN CONT): 10
    transport # PONGs dropped, no matching pending validation: 2
    transport # bytes transmitted via https_client: 8998200
    transport # bytes received via http_client: 122834625
    transport # bytes transmitted via http_client: 11075442
    transport # failed address checks during validation: 68
    transport # bytes received via https_client: 251637047
    transport # messages timed out while in transport queue: 14
    transport # KEEPALIVE messages discarded (peer unknown): 7
    transport # KEEPALIVE messages discarded (no session): 2
    transport # bytes payload dropped (other peer was not connected): 71232
    transport # requests to create session with invalid address: 51
    transport # KEEPALIVE_RESPONSEs discarded (not connected): 1
    transport # unexpected SYN_ACK messages (disconnecting): 1
TagsNo tags attached.

Activities

Christian Grothoff

2017-02-26 02:29

manager   ~0011860

Looking at this:

    transport # validations delayed by global throttle: 56139155
    transport # Addresses in validation map: 719
    transport # validations running: 7993
    transport # validations succeeded: 7010
    transport # PINGs for address validation sent: 66207
    transport # address revalidations started: 111178
    transport # successful address checks during validation: 84372
    transport # requests to create session with invalid address: 32286
    transport # failed address checks during validation: 75757


Looking at the code, it is clear that the 719 map size is what matters
(in terms of memory consumption), and that number seems stable / sufficiently low / not growing too crazy.

Christian Grothoff

2017-02-26 02:33

manager   ~0011861

Closer inspection suggests that we might be really bad at updating the validations_running counter, but do use it for more than stats :-(.

Christian Grothoff

2017-02-26 02:34

manager   ~0011862

Anyway, so this is a (minor) issue, but will go away with transport-NG anyway. Not sure there is a point in fixing it right now.

Christian Grothoff

2018-06-24 19:46

manager   ~0013075

Validation was disabled, as we will transition to sigs soon anyway.

Issue History

Date Modified Username Field Change
2015-07-17 17:15 amatus New Issue
2015-07-17 17:15 amatus Status new => assigned
2015-07-17 17:15 amatus Assigned To => Matthias Wachs
2017-02-26 02:29 Christian Grothoff Note Added: 0011860
2017-02-26 02:33 Christian Grothoff Note Added: 0011861
2017-02-26 02:34 Christian Grothoff Note Added: 0011862
2017-02-26 02:34 Christian Grothoff Assigned To Matthias Wachs =>
2017-02-26 02:34 Christian Grothoff Status assigned => confirmed
2018-06-24 19:46 Christian Grothoff Assigned To => Christian Grothoff
2018-06-24 19:46 Christian Grothoff Status confirmed => resolved
2018-06-24 19:46 Christian Grothoff Resolution open => fixed
2018-06-24 19:46 Christian Grothoff Fixed in Version => 0.11.0pre66
2018-06-24 19:46 Christian Grothoff Note Added: 0013075
2018-06-24 19:46 Christian Grothoff Target Version => 0.11.0
2019-02-16 13:56 Christian Grothoff Status resolved => closed
2019-02-16 13:56 Christian Grothoff Fixed in Version 0.11.0pre66 => 0.11.0