View Issue Details

IDProjectCategoryView StatusLast Update
0003865GNUnetrps servicepublic2019-02-28 11:17
ReporterBart PolotAssigned Toch3 
PrioritynormalSeveritycrashReproducibilityrandom
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0Fixed in Version0.11.0 
Summary0003865: rps profiler crashes
DescriptionJun 26 16:55:32-994606 cadet-31268 DEBUG shut down
Jun 26 16:55:32-994640 cadet-loc-31268 DEBUG client disconnected: (nil)
Jun 26 16:55:32-994646 cadet-loc-31268 DEBUG (SERVER DOWN)
Jun 26 16:55:32-994651 cadet-loc-31268 DEBUG client connected: (nil)
Jun 26 16:55:33-002219 test-rps-profiler-31019 ERROR Assertion failed at testbed_api_testbed.c:463.

(gdb) bt
#0 0x00007f5003aca528 in raise () from /usr/lib/libc.so.6
#1 0x00007f5003acb93a in abort () from /usr/lib/libc.so.6
#2 0x00007f5005e400d7 in GNUNET_abort_ () at common_logging.c:290
#3 0x00007f5005c159d0 in cleanup (rc=0x13b1b90) at testbed_api_testbed.c:463
#4 0x00007f5005c160cb in wait_op_completion (cls=0x13b1b90) at testbed_api_testbed.c:606
#5 0x00007f5005c01515 in GNUNET_TESTBED_remove_opc_ (c=0x13e4850, opc=0x172a5a0) at testbed_api.c:357
#6 0x00007f5005c019cd in handle_opsuccess (c=0x13e4850, msg=0x7fffda31caf0) at testbed_api.c:466
#7 0x00007f5005c0463c in message_handler (cls=0x13e4850, msg=0x7fffda31caf0) at testbed_api.c:1100
#8 0x00007f5005e3a8e9 in receive_task (cls=0x13f4730, tc=0x7fffda31cbd0) at client.c:618
#9 0x00007f5005e7af17 in run_ready (rs=0x1385a60, ws=0x1385af0) at scheduler.c:587
#10 0x00007f5005e7b827 in GNUNET_SCHEDULER_run (task=0x7f5005e75b25 <program_main>, task_cls=0x7fffda31ce70)
    at scheduler.c:867
#11 0x00007f5005e766eb in GNUNET_PROGRAM_run2 (argc=3, argv=0x7fffda31d010, binaryName=0x405229 "test-rps-profiler",
    binaryHelp=0x7f5005c21d89 "nohelp", options=0x7fffda31cfd0, task=0x7f5005c19337 <run>, task_cls=0x1383890,
    run_without_scheduler=0) at program.c:302
#12 0x00007f5005e76842 in GNUNET_PROGRAM_run (argc=3, argv=0x7fffda31d010, binaryName=0x405229 "test-rps-profiler",
    binaryHelp=0x7f5005c21d89 "nohelp", options=0x7fffda31cfd0, task=0x7f5005c19337 <run>, task_cls=0x1383890)
    at program.c:341
#13 0x00007f5005c19635 in GNUNET_TESTBED_test_run (testname=0x405229 "test-rps-profiler",
    cfg_filename=0x405245 "test_rps.conf", num_peers=50, event_mask=0, cc=0x0, cc_cls=0x0, test_master=0x403f3b <run>,
    test_master_cls=0x0) at testbed_api_test.c:151
#14 0x0000000000404a85 in main (argc=1, argv=0x7fffda31d198) at test_rps.c:1205
Additional Information(gdb) bt full
#0 0x00007f5003aca528 in raise () from /usr/lib/libc.so.6
No symbol table info available.
#1 0x00007f5003acb93a in abort () from /usr/lib/libc.so.6
No symbol table info available.
#2 0x00007f5005e400d7 in GNUNET_abort_ () at common_logging.c:290
No locals.
#3 0x00007f5005c159d0 in cleanup (rc=0x13b1b90) at testbed_api_testbed.c:463
        hid = 0
        __FUNCTION__ = "cleanup"
#4 0x00007f5005c160cb in wait_op_completion (cls=0x13b1b90) at testbed_api_testbed.c:606
        rc = 0x13b1b90
        rcop = 0xffffffff
        __FUNCTION__ = "wait_op_completion"
#5 0x00007f5005c01515 in GNUNET_TESTBED_remove_opc_ (c=0x13e4850, opc=0x172a5a0) at testbed_api.c:357
        __FUNCTION__ = "GNUNET_TESTBED_remove_opc_"
#6 0x00007f5005c019cd in handle_opsuccess (c=0x13e4850, msg=0x7fffda31caf0) at testbed_api.c:466
        opc = 0x172a5a0
        op_comp_cb = 0x0
        op_comp_cb_cls = 0x0
        event = {type = GNUNET_TESTBED_ET_OPERATION_FINISHED, op = 0x17293a0, op_cls = 0x172a170, details = {
            peer_start = {host = 0x0, peer = 0x0}, peer_stop = {peer = 0x0}, peer_connect = {peer1 = 0x0,
              peer2 = 0x0}, peer_disconnect = {peer1 = 0x0, peer2 = 0x0}, operation_finished = {emsg = 0x0,
              generic = 0x0}}}
        op_id = 666
        __FUNCTION__ = "handle_opsuccess"
#7 0x00007f5005c0463c in message_handler (cls=0x13e4850, msg=0x7fffda31caf0) at testbed_api.c:1100
        c = 0x13e4850
        status = 0
        msize = 16
        __FUNCTION__ = "message_handler"
#8 0x00007f5005e3a8e9 in receive_task (cls=0x13f4730, tc=0x7fffda31cbd0) at client.c:618
        client = 0x13f4730
        handler = 0x7f5005c043b8 <message_handler>
        cmsg = 0x1403ef0
        handler_cls = 0x13e4850
        msize = 16
        mbuf = <error reading variable mbuf (frame address is not available.)>
        msg = 0x7fffda31caf0
        __FUNCTION__ = "receive_task"
#9 0x00007f5005e7af17 in run_ready (rs=0x1385a60, ws=0x1385af0) at scheduler.c:587
        p = GNUNET_SCHEDULER_PRIORITY_DEFAULT
        pos = 0x173a020
        tc = {reason = GNUNET_SCHEDULER_REASON_TIMEOUT, read_ready = 0x1385a60, write_ready = 0x1385af0}
        __FUNCTION__ = "run_ready"
#10 0x00007f5005e7b827 in GNUNET_SCHEDULER_run (task=0x7f5005e75b25 <program_main>, task_cls=0x7fffda31ce70)
    at scheduler.c:867
        rs = 0x1385a60
        ws = 0x1385af0
        timeout = {rel_value_us = 0}
        ret = 0
        shc_int = 0x13c6e30
        shc_term = 0x13c6ef0
        shc_quit = 0x13c7070
        shc_hup = 0x13c7130
        shc_pipe = 0x13c6fb0
        last_tr = 2574
        busy_wait_warning = 0
        pr = 0x13c6cb0
        c = 0 '\000'
        __FUNCTION__ = "GNUNET_SCHEDULER_run"
#11 0x00007f5005e766eb in GNUNET_PROGRAM_run2 (argc=3, argv=0x7fffda31d010, binaryName=0x405229 "test-rps-profiler",
    binaryHelp=0x7f5005c21d89 "nohelp", options=0x7fffda31cfd0, task=0x7f5005c19337 <run>, task_cls=0x1383890,
    run_without_scheduler=0) at program.c:302
        cc = {args = 0x7fffda31d028, cfgfile = 0x1385cd0 "test_rps.conf", task = 0x7f5005c19337 <run>,
---Type <return> to continue, or q <return> to quit---
          task_cls = 0x1383890, cfg = 0x1383a60}
        path = 0x13859b0 "\002"
        loglev = 0x0
        logfile = 0x0
        cfg_fn = 0x1385ba0 "~/.config/gnunet.conf"
        xdg = 0x0
        ret = 3
        cnt = 5
        skew_offset = 0
        skew_variance = 140736854086032
        clock_offset = 0
        cfg = 0x1383a60
        defoptions = {{shortName = 99 'c', name = 0x7f5005e969d0 "config", argumentHelp = 0x7f5005e969d7 "FILENAME",
            description = 0x7f5005e969e0 "use configuration file FILENAME", require_argument = 1,
            processor = 0x7f5005e68255 <GNUNET_GETOPT_set_string>, scls = 0x7fffda31ce78}, {shortName = 104 'h',
            name = 0x7f5005e96a00 "help", argumentHelp = 0x0, description = 0x7f5005e96a05 "print this help",
            require_argument = 0, processor = 0x7f5005e67cf3 <GNUNET_GETOPT_format_help_>, scls = 0x7f5005c21d89}, {
            shortName = 76 'L', name = 0x7f5005e96a15 "log", argumentHelp = 0x7f5005e96a19 "LOGLEVEL",
            description = 0x7f5005e96a28 "configure logging to use LOGLEVEL", require_argument = 1,
            processor = 0x7f5005e68255 <GNUNET_GETOPT_set_string>, scls = 0x7fffda31ce68}, {shortName = 108 'l',
            name = 0x7f5005e96a4a "logfile", argumentHelp = 0x7f5005e96a52 "LOGFILE",
            description = 0x7f5005e96a60 "configure logging to write logs to LOGFILE", require_argument = 1,
            processor = 0x7f5005e68255 <GNUNET_GETOPT_set_string>, scls = 0x7fffda31ce60}, {shortName = 118 'v',
            name = 0x7f5005e96a8b "version", argumentHelp = 0x0,
            description = 0x7f5005e96a93 "print the version number", require_argument = 0,
            processor = 0x7f5005e67cad <GNUNET_GETOPT_print_version_>, scls = 0x7f5005e96aac}}
        allopts = 0x1385a40
        gargs = 0x0
        lpfx = 0x1385bc0 "\320j<\001"
        spc = 0x0
        __FUNCTION__ = "GNUNET_PROGRAM_run2"
#12 0x00007f5005e76842 in GNUNET_PROGRAM_run (argc=3, argv=0x7fffda31d010, binaryName=0x405229 "test-rps-profiler",
    binaryHelp=0x7f5005c21d89 "nohelp", options=0x7fffda31cfd0, task=0x7f5005c19337 <run>, task_cls=0x1383890)
    at program.c:341
No locals.
#13 0x00007f5005c19635 in GNUNET_TESTBED_test_run (testname=0x405229 "test-rps-profiler",
    cfg_filename=0x405245 "test_rps.conf", num_peers=50, event_mask=0, cc=0x0, cc_cls=0x0, test_master=0x403f3b <run>,
    test_master_cls=0x0) at testbed_api_test.c:151
        argv2 = {0x1383850 "test-rps-profiler", 0x7f5005c21d50 "-c", 0x1383870 "test_rps.conf", 0x0}
        options = {{shortName = 0 '\000', name = 0x0, argumentHelp = 0x0, description = 0x0, require_argument = 0,
            processor = 0x0, scls = 0x0}}
        rc = 0x1383890
        ret = 0
        __FUNCTION__ = "GNUNET_TESTBED_test_run"
#14 0x0000000000404a85 in main (argc=1, argv=0x7fffda31d198) at test_rps.c:1205
        __FUNCTION__ = "main"
(gdb)
TagsNo tags attached.

Activities

Bart Polot

2015-06-26 17:08

manager   ~0009346

It *might* be a testbed bug, but I have never seen it before. If you are confident that it's testbed's fault, reassign to Sree Harsha.

ch3

2015-06-26 19:09

developer   ~0009349

I'm not able to reproduce that.
But I guess I did not mark all operations as done.

Issue History

Date Modified Username Field Change
2015-06-26 17:06 Bart Polot New Issue
2015-06-26 17:06 Bart Polot Status new => assigned
2015-06-26 17:06 Bart Polot Assigned To => ch3
2015-06-26 17:08 Bart Polot Note Added: 0009346
2015-06-26 19:09 ch3 Note Added: 0009349
2018-08-13 14:24 ch3 Status assigned => resolved
2018-08-13 14:24 ch3 Resolution open => fixed
2019-02-12 09:20 Christian Grothoff Target Version => 0.11.0
2019-02-20 12:24 Christian Grothoff Fixed in Version => 0.11.0
2019-02-28 11:17 Christian Grothoff Status resolved => closed