View Issue Details

IDProjectCategoryView StatusLast Update
0003837GNUnetbuild processpublic2018-06-07 00:24
ReporterellAssigned ToJeff Burdges 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformXubu-64amdOSOS Version
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003837: Revision 35927, make fails
Descriptionmake[4]: Verzeichnis »/home/ell/gnunet/src/gns« wird verlassen
make[3]: Verzeichnis »/home/ell/gnunet/src/gns« wird verlassen
Making install in nss
make[3]: Verzeichnis »/home/ell/gnunet/src/gns/nss« wird betreten
make[4]: Verzeichnis »/home/ell/gnunet/src/gns/nss« wird betreten
make[4]: Für das Ziel »install-exec-am« ist nichts zu tun.
LIBTOOL_SUDO_BINARY = sudo
/bin/bash: LIBTOOL_SUDO_BINARY: Befehl nicht gefunden
make[4]: *** [install-nssLTLIBRARIES] Fehler 127
make[4]: Verzeichnis »/home/ell/gnunet/src/gns/nss« wird verlassen
make[3]: *** [install-am] Fehler 2
make[3]: Verzeichnis »/home/ell/gnunet/src/gns/nss« wird verlassen
make[2]: *** [install-recursive] Fehler 1
make[2]: Verzeichnis »/home/ell/gnunet/src/gns« wird verlassen
make[1]: *** [install-recursive] Fehler 1
make[1]: Verzeichnis »/home/ell/gnunet/src« wird verlassen
make: *** [install-recursive] Fehler 1
TagsNo tags attached.

Activities

Jeff Burdges

2015-06-15 23:19

developer   ~0009289

Can you tell me what make you're using? If it's not GNU make, then that's the issue. We should still fix this since many system avoid GNU make, like maybe OS X.

I pushed a change that *might* fix it for your make. Can you try it? If this doesn't work, then I'll need to test for GNU make probably, but not quite sure how yet.

Anything else you can tell me about the system?

ell

2015-06-16 09:22

reporter   ~0009290

ell@Xubu-14:~$ uname -a
Linux Xubu-14 3.13.0-55-generic #92-Ubuntu SMP Sun Jun 14 18:32:20 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
ell@Xubu-14:~$

ell@Xubu-14:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.2 LTS
Release: 14.04
Codename: trusty
ell@Xubu-14:~$

ell@Xubu-14:~$ make -v
GNU Make 3.81
...
ell@Xubu-14:~$

ell@Xubu-14:~$ cd gnunet
ell@Xubu-14:~/gnunet$ svn up
Aktualisiere ».«:
U src/gns/nss/Makefile.am
Aktualisiert zu Revision 35933.
ell@Xubu-14:~/gnunet$ sudo make install

++++ This run is ok ++++

Jeff Burdges

2015-06-16 11:57

developer   ~0009291

Alright, thanks! It's maybe a slight change in the syntax then. I'm running GNU make 4 here.

Jeff Burdges

2015-08-06 10:32

developer   ~0009542

We fixed this in r35933, right?

ell

2015-08-19 14:23

reporter   ~0009577

I think it is fixed in r35933, but I updated my make-3.81 meanwhile to make-4.1.

Issue History

Date Modified Username Field Change
2015-06-12 09:36 ell New Issue
2015-06-13 17:37 Christian Grothoff Assigned To => Jeff Burdges
2015-06-13 17:37 Christian Grothoff Status new => assigned
2015-06-15 23:19 Jeff Burdges Note Added: 0009289
2015-06-16 09:22 ell Note Added: 0009290
2015-06-16 11:57 Jeff Burdges Note Added: 0009291
2015-08-06 10:32 Jeff Burdges Note Added: 0009542
2015-08-06 14:56 Christian Grothoff Status assigned => feedback
2015-08-06 14:56 Christian Grothoff Target Version => 0.11.0pre66
2015-08-19 14:23 ell Note Added: 0009577
2015-08-19 14:23 ell Status feedback => assigned
2015-08-21 21:07 Christian Grothoff Status assigned => resolved
2015-08-21 21:07 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-08-21 21:07 Christian Grothoff Resolution open => fixed
2018-06-07 00:24 Christian Grothoff Status resolved => closed