View Issue Details

IDProjectCategoryView StatusLast Update
0003703gnunet-gtkgnunet-fs-gtkpublic2018-06-07 00:24
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003703: crash in gnunet-fs-gtk after WARNING External protocol violation detected at container_meta_data.c:1123.
Description#0 0x00007f6ad4807614 in g_type_check_instance_cast () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
(gdb) ba
#0 0x00007f6ad4807614 in g_type_check_instance_cast () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#1 0x000000000041568c in mark_download_progress (de=0xd7af80,
    filename=0x1df1500 "/home/grothoff/Downloads/fn", size=57694233, completed=0,
    block_data=0x7fffee14eb20, offset=8388608, block_size=32768, depth=1) at gnunet-fs-gtk_event-handler.c:2928
#2 0x000000000041851f in GNUNET_GTK_fs_event_handler (cls=0x0, info=0x7fffee156b40) at gnunet-fs-gtk_event-handler.c:3924
#3 0x00007f6ad6f03885 in GNUNET_FS_download_make_status_ (pi=0x7fffee156b40, dc=0x1df1550) at fs_download.c:127
#4 0x00007f6ad6f075c7 in process_result_with_request (cls=0x7fffee156df0, key=0x7fffee156df0, value=0x2d7a100) at fs_download.c:1107
#5 0x00007f6ad7565f61 in GNUNET_CONTAINER_multihashmap_get_multiple (map=0xf444d0, key=0x7fffee156df0,
    it=0x7f6ad6f067ca <process_result_with_request>, it_cls=0x7fffee156df0) at container_multihashmap.c:789
#6 0x00007f6ad6f08417 in process_result (dc=0x1df1550, type=GNUNET_BLOCK_TYPE_FS_IBLOCK, respect_offered=0, num_transmissions=2,
    last_transmission=..., data=0x7fffee156f20, size=32768) at fs_download.c:1254
#7 0x00007f6ad6f085af in receive_results (cls=0x1df1550, msg=0x7fffee156f00) at fs_download.c:1283
#8 0x00007f6ad754f193 in receive_task (cls=0x1154da0, tc=0x7fffee15eff0) at client.c:618
#9 0x00007f6ad758d47c in run_ready (rs=0x8451e0, ws=0x8456b0) at scheduler.c:587
#10 0x00007f6ad758dd87 in GNUNET_SCHEDULER_run (task=0x7f6ad758839c <program_main>, task_cls=0x7fffee15f290) at scheduler.c:867
#11 0x00007f6ad7588f1e in GNUNET_PROGRAM_run2 (argc=1, argv=0x7fffee15f598, binaryName=0x426578 "gnunet-fs-gtk",
    binaryHelp=0x426b50 "GTK GUI for GNUnet", options=0x62e0c0 <options>, task=0x7f6ad8204d4c <run_main_loop>, task_cls=0x7fffee15f3f0,
    run_without_scheduler=0) at program.c:286
#12 0x00007f6ad7589075 in GNUNET_PROGRAM_run (argc=1, argv=0x7fffee15f598, binaryName=0x426578 "gnunet-fs-gtk",
    binaryHelp=0x426b50 "GTK GUI for GNUnet", options=0x62e0c0 <options>, task=0x7f6ad8204d4c <run_main_loop>, task_cls=0x7fffee15f3f0)
    at program.c:325
#13 0x00007f6ad820526d in GNUNET_GTK_main_loop_start (binary_name=0x426578 "gnunet-fs-gtk", binary_help=0x426b50 "GTK GUI for GNUnet",
    argc=1, argv=0x7fffee15f598, options=0x62e0c0 <options>, main_window_file=0x426b30 "gnunet_fs_gtk_main_window.glade",
    main_task=0x40d4f5 <run>) at eventloop.c:919
#14 0x000000000040de71 in main (argc=1, argv=0x7fffee15f598) at gnunet-fs-gtk.c:898
Steps To ReproduceHappened suddenly just after starting search in gnunet-fs-gtk.
TagsNo tags attached.

Activities

Christian Grothoff

2015-03-07 14:29

manager   ~0008985

This is the where the crash happens:

    GNUNET_assert (gtk_tree_model_get_iter (GTK_TREE_MODEL (de->sr->tab->ts),
                                            &iter, path));

The assertion is not what is failing, we're crashing because of memory corruption during the check.

Issue History

Date Modified Username Field Change
2015-03-07 14:20 Christian Grothoff New Issue
2015-03-07 14:22 Christian Grothoff Assigned To => Christian Grothoff
2015-03-07 14:22 Christian Grothoff Status new => assigned
2015-03-07 14:29 Christian Grothoff Note Added: 0008985
2015-03-07 14:32 Christian Grothoff Steps to Reproduce Updated View Revisions
2015-03-07 19:30 Christian Grothoff Severity tweak => crash
2015-03-21 00:38 Christian Grothoff Target Version => 0.11.0
2017-03-10 21:22 Christian Grothoff Status assigned => resolved
2017-03-10 21:22 Christian Grothoff Resolution open => fixed
2017-03-10 21:22 Christian Grothoff Fixed in Version => 0.11.0pre66
2017-03-10 21:22 Christian Grothoff Target Version 0.11.0 => 0.11.0pre66
2018-06-07 00:24 Christian Grothoff Status resolved => closed