View Issue Details

IDProjectCategoryView StatusLast Update
0003695GNUnetUDP transportpublic2018-06-07 00:25
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003695: UDP reports multiple session instances to same peer
DescriptionFeb 28 17:48:27-700752 transport-udp-6348 DEBUG Session 0x73bbc50 to peer `18ZQ' address ended
Feb 28 17:48:27-700952 transport-udp-6348 DEBUG Session 0x93cd890 to peer `SJ4Z' address ended
Feb 28 17:48:27-701142 transport-udp-6348 DEBUG Session 0x73a7690 to peer `GN10' address ended
Feb 28 17:48:27-701338 transport-udp-6348 DEBUG Session 0x8270b10 to peer `8CE9' address ended
Feb 28 17:48:27-701539 transport-udp-6348 DEBUG Session 0x94ea1d0 to peer `0VJZ' address ended
Feb 28 17:48:27-701755 transport-udp-6348 DEBUG Session 0x95509a0 to peer `0VJZ' address ended
Feb 28 17:48:27-701937 transport-udp-6348 DEBUG Session 0x88012a0 to peer `MSQA' address ended
Feb 28 17:48:27-702136 transport-udp-6348 DEBUG Session 0x954f820 to peer `0VJZ' address ended
Feb 28 17:48:27-702345 transport-udp-6348 DEBUG Session 0x9552250 to peer `0VJZ' address ended
Feb 28 17:48:27-702528 transport-udp-6348 DEBUG Session 0x7def010 to peer `P00P' address ended
Feb 28 17:48:27-702714 transport-udp-6348 DEBUG Session 0x8f2cfd0 to peer `P00P' address ended
Feb 28 17:48:27-702900 transport-udp-6348 DEBUG Session 0x73a8000 to peer `GN10' address ended
Feb 28 17:48:27-703086 transport-udp-6348 DEBUG Session 0x7df39b0 to peer `4Z8G' address ended

This may cause unexpected memory utilization. (Note that the peer this was on only supports IPv4).
TagsNo tags attached.

Relationships

related to 0003684 closedChristian Grothoff Revision 35254: Overnight run fills memory and swap completely 

Activities

Christian Grothoff

2015-03-02 10:31

manager   ~0008960

Updated logging shows that this seems to be really just multiple addresses (v4/v6). Or the bug was fixed.

Issue History

Date Modified Username Field Change
2015-02-28 17:51 Christian Grothoff New Issue
2015-02-28 17:51 Christian Grothoff Status new => assigned
2015-02-28 17:51 Christian Grothoff Assigned To => Matthias Wachs
2015-02-28 17:51 Christian Grothoff Relationship added related to 0003684
2015-02-28 17:54 Christian Grothoff Assigned To Matthias Wachs => Christian Grothoff
2015-02-28 18:36 Christian Grothoff Target Version => 0.11.0pre66
2015-03-02 10:31 Christian Grothoff Note Added: 0008960
2015-03-02 10:31 Christian Grothoff Status assigned => resolved
2015-03-02 10:31 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-03-02 10:31 Christian Grothoff Resolution open => fixed
2018-06-07 00:25 Christian Grothoff Status resolved => closed