View Issue Details

IDProjectCategoryView StatusLast Update
0003685GNUnetpeerinfo servicepublic2018-06-07 00:25
ReporteramatusAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003685: Receiving many useless HELLOs through gossip frequently with peer IDs starting with Z
DescriptionI don't know if HELLOs are getting corrupted or if these are actual peer IDs that someone generated. They don't seem to have any transport addresses, so they are never verified and written to peerinfo's store. I don't know if these are being actively created/corrupted or if they are just zombie HELLOs that stay on the network because enough peers are keeping them in RAM and gossiping about them.

Peer `Z1WMBT7J39JM31M9YGQ16CRJN0KWWXPTFV1XMZFFES4V8WT206Q0'
Peer `Z4E4ZDCRN0CEW2599DGE613NDVEMSWW57EG5TXS40SQV3JKM8CE0'
Peer `Z70YQ47EC8FDBK9KG1QDC728E6FN5XXFXGYTCM0V52DK8VZ78ZMG'
Peer `Z88V0ZZQNJRP8GE8ZDVJBP3QC27FCAQE3TN3G3CBVMXVZDCMQFA0'
Peer `Z8AFTM4S8AV7KH7CCDNDB07XFTJ9A3X79AWTC17GYHFJRKR280H0'
Peer `Z8VE64DRPT7RTM0JGGWBQHQTPRRH4TN3T1HP50RBGN3Z9CFBH0EG'
Peer `Z8ZPPHWYDPVZ1SGF3WHJ84YQQPHK67JJ6FNS9V8WRBNDXBFERB5G'
Peer `Z9M7X7B1BK9F5V8JQB16NJRH5ESHCN3C2G9B7YWDHMMQW84VRS2G'
Peer `ZAKZE28RXJSGKEW7ZCT24FEKP723R387EDKYEP9PVDA20FHS56EG'
Peer `ZB05DVDQK63XCPB37408F33YC11NRQZRS5KCDF0W0195PZVQK1MG'
Peer `ZBDZQ9XZ1HFFNQHV95XDTQP0WC39JYHMQGJJVDM58G246CHD5H70'
Peer `ZBHWE5MFCF9WFMCD7KZGFRWNT4TSJYV2YBRQMW5SBPHEJYP1A1N0'
Peer `ZBR0WSHXB59Q61093HN9RANQ8KNJ55J3Q5AM4483XCBDZWBMQY0G'
Peer `ZDN9H6ZJ2YFGXXPS7WAGWSDE2S22QRGFC67F68WZCKM31RJZ6J5G'
Peer `ZGV0TT38ZHA4CS1HHZ93SA1NNBN4T5AE4SHZNEW4G64EGFNJB7H0'
Peer `ZH9S1S4T8KBKHBHQPTN5SJK1RN2PTKBF1R4SJHGEGG610GDZP650'
Peer `ZHQ4NNR2Z9BDCANMTF834A6AAYB6MWCC8J70YR2W5GSTTJDFN53G'
Peer `ZKA66S1CMVRPTNY141V6DDP2JWZGMPG8XT9S9GC0A0VKE1CEY23G'
Peer `ZKH69HQPDX2G5XVG92AWPFGG4584QB1Q4YKV9XFGFGZFBBPVH2CG'
Peer `ZN5HHCT1R9H1ZHDDB7PFECMDKKKA2FQE356R2XA04FPY4PC8PVNG'
Peer `ZNX0SA2DEH1AW7K78V6MP4KDPQQQKH391BBJJ5CC8G6EB3YZX94G'
Peer `ZP9SN70450QG89WYMXKN3NK5QQ6WAV24Y0BJ9FW5GZA4EJBCFR60'
Peer `ZR5BP8W7WGTH1BJJHC5WQMMY031D6KZH1SSMQA52TNF86C8YQ4JG'
Peer `ZRFKM2WCGYYWJSCBJBSCB2Q7F8199722CFWV1A1FF1NFXF75RCS0'
Peer `ZT5KFCVTJ213TB219PEEEXAHJY2B7D1AX76YC385755K1H763M2G'
Peer `ZTPEXGRV3555N9E6V0NDVW3G74GH20P68AXZQ296DP9PQ7MWPN3G'
Peer `ZY6HBSGKTTJ499K2BGSQ383QBXMCH5FWDZG5EY8CXJYK3A69KHFG'
Peer `ZYANBTYSR8FFT660DG17XPJ776CZ82NW7K3KSE89J7318KAHRWAG'
Steps To Reproduce1. Run a peer overnight.
2. gnunet-peerinfo -in | grep -A 1 \`Z
TagsNo tags attached.

Activities

amatus

2015-02-15 18:36

developer   ~0008880

I haven't seen any new ones appear since yesterday, just the same 28 listed above.

Christian Grothoff

2015-02-17 19:32

manager   ~0008883

We clearly need to disable gossiping without addresses, and not store information in peerinfo about peers without addresses. (This used to be different in the past, when we needed the public keys, but now with public keys being the addresses, we really don't need to store address-less HELLOs)

Christian Grothoff

2015-02-22 23:13

manager   ~0008916

SVN 35297 should at least lessen the issue: transport no longer reports address-less HELLOs to peerinfo.

Christian Grothoff

2015-02-28 18:39

manager   ~0008949

I don't see a problem with Z-peers in SVN HEAD anymore.

Issue History

Date Modified Username Field Change
2015-02-14 17:47 amatus New Issue
2015-02-15 18:36 amatus Note Added: 0008880
2015-02-17 19:32 Christian Grothoff Note Added: 0008883
2015-02-22 23:13 Christian Grothoff Note Added: 0008916
2015-02-22 23:13 Christian Grothoff Assigned To => Christian Grothoff
2015-02-22 23:13 Christian Grothoff Status new => feedback
2015-02-28 18:39 Christian Grothoff Note Added: 0008949
2015-02-28 18:39 Christian Grothoff Status feedback => resolved
2015-02-28 18:39 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-02-28 18:39 Christian Grothoff Resolution open => fixed
2015-02-28 18:40 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed