View Issue Details

IDProjectCategoryView StatusLast Update
0003683GNUnettransport servicepublic2018-06-07 00:25
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003683: peers fail to respond to PING
DescriptionWhen a peer runs "for some time" (hours?), it at some point stops responding to (certain?) PING requests. This was confirmed with 'gnunet9' not responding to PINGs from my own system. Note that my own system was configured to ONLY use TCP.

My current suspicion is that there might be a connection counting issue, which might have caused gnunet.org to stop accepting incoming TCP connections (GNUNET_SERVER_suspend) and thus never see the PINGs (and if the PING is not received, it won't be answered either). I've added # TCP service suspended|resumed stats to track such events.

However, the cause could be different, but still the fact that peers end up disconnected would be totally explained by long-running peers no longer responding to PINGs.
TagsNo tags attached.

Relationships

related to 0003687 closedChristian Grothoff WARNING `accept' failed at connection.c:345 with error: Resource temporarily unavailable 
child of 0003448 closedChristian Grothoff Core-level (transport? ats?) connectivity problems 

Activities

Christian Grothoff

2015-02-18 00:34

manager   ~0008886

These stats (from gnunet9) shows that really the suspend/resume of the TCP service is to blame:

    transport # bytes transmitted via TCP: 1447426911
    transport # bytes currently in TCP buffers: 0
    transport # bytes received via TCP: 5389990419
    transport # TCP sessions active: 1
    transport # TCP service suspended: 166
    transport # TCP WELCOME messages received: 502
    transport # bytes discarded by TCP (disconnect): 773865
    transport # network-level TCP disconnect events: 1971
    transport # TCP service resumed: 165
    transport # bytes discarded by TCP (timeout): 11860

Christian Grothoff

2015-02-18 15:08

manager   ~0008890

Fixed the counting logic (significant simplification) in SVN 35283. This should fix this issue.

Christian Grothoff

2015-02-19 14:18

manager   ~0008897

Suspending still seems to happen. But see also 0003687.

Christian Grothoff

2015-02-21 22:52

manager   ~0008909

Maybe resolved together with 0003687 now, but should keep observing a bit longer.

Christian Grothoff

2015-02-28 14:41

manager   ~0008932

I still see TCP service suspended-events (and > resumed). Very odd.

Christian Grothoff

2015-02-28 18:26

manager   ~0008942

We still sometimes (briefly) suspend the TCP server, but that's because we really hit the 128-connection limit. But in this case, we do resume now.

Issue History

Date Modified Username Field Change
2015-02-12 20:57 Christian Grothoff New Issue
2015-02-12 20:57 Christian Grothoff Status new => assigned
2015-02-12 20:57 Christian Grothoff Assigned To => Matthias Wachs
2015-02-12 20:58 Christian Grothoff Relationship added child of 0003448
2015-02-12 21:16 Christian Grothoff Summary peers fail to respond to PONG => peers fail to respond to PING
2015-02-12 21:16 Christian Grothoff Description Updated View Revisions
2015-02-18 00:34 Christian Grothoff Note Added: 0008886
2015-02-18 15:08 Christian Grothoff Note Added: 0008890
2015-02-18 15:08 Christian Grothoff Status assigned => resolved
2015-02-18 15:08 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-02-18 15:08 Christian Grothoff Resolution open => fixed
2015-02-18 15:08 Christian Grothoff Assigned To Matthias Wachs => Christian Grothoff
2015-02-19 14:18 Christian Grothoff Note Added: 0008897
2015-02-19 14:18 Christian Grothoff Status resolved => feedback
2015-02-19 14:18 Christian Grothoff Resolution fixed => reopened
2015-02-19 14:19 Christian Grothoff Relationship added related to 0003687
2015-02-21 22:52 Christian Grothoff Note Added: 0008909
2015-02-21 22:52 Christian Grothoff Status feedback => assigned
2015-02-28 14:41 Christian Grothoff Note Added: 0008932
2015-02-28 18:26 Christian Grothoff Note Added: 0008942
2015-02-28 18:26 Christian Grothoff Status assigned => resolved
2015-02-28 18:26 Christian Grothoff Resolution reopened => fixed
2018-06-07 00:25 Christian Grothoff Status resolved => closed