View Issue Details

IDProjectCategoryView StatusLast Update
0003675GNUnettransport servicepublic2018-06-07 00:24
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PrioritylowSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003675: eliminate use of GNUNET_TRANSPORT_try_connect()
DescriptionApplications that want to have connections should contact ATS, not transport in the future. Also, transport should ask ATS for suggestions for addresses of connected peers only initially, not long-term.

Finally, ATS solvers should select peers for scheduling even if there are no explicit connection requests (after all, ATS is supposed to ensure a minimum degree of connectivity!)
TagsNo tags attached.

Relationships

related to 0003659 closedChristian Grothoff allow specification of strength of request for GNUNET_ATS_connectivity_suggest() 

Activities

Christian Grothoff

2015-11-07 00:47

manager   ~0009876

SVN 36646 removed some related logic that *should* be dead and no longer required. However, if suddenly something breaks, this is the revision to consider undoing (as it simplifies error handling on one path to be able to remove more code). SVN 36645 removes the logic that is now really dead for sure due to refactoring.

Issue History

Date Modified Username Field Change
2015-02-11 20:14 Christian Grothoff New Issue
2015-02-11 20:14 Christian Grothoff Status new => assigned
2015-02-11 20:14 Christian Grothoff Assigned To => Matthias Wachs
2015-02-11 20:14 Christian Grothoff Relationship added related to 0003659
2015-02-11 20:33 Christian Grothoff Assigned To Matthias Wachs =>
2015-02-11 20:33 Christian Grothoff Status assigned => confirmed
2015-03-08 20:23 Christian Grothoff Assigned To => Christian Grothoff
2015-03-08 20:23 Christian Grothoff Status confirmed => assigned
2015-08-09 00:45 Christian Grothoff Priority normal => low
2015-11-07 00:47 Christian Grothoff Note Added: 0009876
2015-11-07 00:47 Christian Grothoff Status assigned => resolved
2015-11-07 00:47 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-11-07 00:47 Christian Grothoff Resolution open => fixed
2015-11-07 00:47 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:24 Christian Grothoff Status resolved => closed