View Issue Details

IDProjectCategoryView StatusLast Update
0003652GNUnettransport servicepublic2018-06-07 00:25
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PriorityurgentSeverityblockReproducibilityN/A
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003652: inbound quota is enforced, but ignored by sender, leading to connectivity issues
DescriptionIn the "test_transport_api_switch" testcases, it seems that the sender sometimes sends at 8kb/s (based on sender's ATS allocation) while the receiver still limits to 1kb/s (not sure why receiver ATS doesn't increase, but obviously that can happen in practice).

However, the receivers inbound quota seems to not be communicated (design issue!?), and the receiver then tries to enforce it by throttling reads (if possible, i.e. on TCP). In the test, I've seen this cause sender-throttling of reads by > 35s. The result was then that a "SYN_ACK" was not received in time because of the read-throttle, causing a address switch by ATS to fail (no SYN_ACK within 15s = failure).
TagsNo tags attached.

Relationships

related to 0003575 closedBart Polot Core takes an arbitrarily long time to call back 

Activities

Christian Grothoff

2015-03-02 01:06

manager   ~0008956

SVN 35335 defines a quota message and makes sure peers receiving it don't complain. But it is neither generated nor are appropriate actions taken when it is received (yet).

Christian Grothoff

2015-03-07 21:42

manager   ~0008989

SVN 35357 makes sure that IF a peer gets a quota message, it handles it appropriately and throttles transmission. But we still do not generate those messages.

Christian Grothoff

2015-03-08 16:57

manager   ~0009005

Should be full implemented in SVN 35362.

Issue History

Date Modified Username Field Change
2015-02-05 01:50 Christian Grothoff New Issue
2015-02-05 01:50 Christian Grothoff Status new => assigned
2015-02-05 01:50 Christian Grothoff Assigned To => Matthias Wachs
2015-02-09 00:19 Christian Grothoff Target Version => 0.11.0pre66
2015-02-11 20:18 Christian Grothoff Relationship added related to 0003575
2015-02-11 20:31 Christian Grothoff Assigned To Matthias Wachs =>
2015-02-11 20:31 Christian Grothoff Status assigned => confirmed
2015-02-28 15:43 Christian Grothoff Relationship added child of 0003448
2015-02-28 18:32 Christian Grothoff Relationship deleted child of 0003448
2015-02-28 18:34 Christian Grothoff Assigned To => Christian Grothoff
2015-02-28 18:34 Christian Grothoff Status confirmed => assigned
2015-03-02 01:06 Christian Grothoff Note Added: 0008956
2015-03-07 21:42 Christian Grothoff Note Added: 0008989
2015-03-08 16:57 Christian Grothoff Note Added: 0009005
2015-03-08 16:57 Christian Grothoff Status assigned => resolved
2015-03-08 16:57 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-03-08 16:57 Christian Grothoff Resolution open => fixed
2018-06-07 00:25 Christian Grothoff Status resolved => closed