View Issue Details

IDProjectCategoryView StatusLast Update
0003650GNUnetATS servicepublic2018-06-07 00:25
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PriorityimmediateSeverityblockReproducibilitysometimes
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003650: ATS (sometimes) fails to suggest address
DescriptionAfter ATS had to "shutdown" a connection to a peer (i.e. due to peer restart), and after being given "new" (verified, valid, working) addresses for that very peer, and a request to suggest an address, ATS sometimes fails to suggest an address despite bandwidth and addresses being available. See log excerpt below.
Steps To ReproduceObserved in failing test_transport_api_restart_1peer testcase, but also others. Seems random.
Additional InformationFeb 05 01:27:21-443332 transport-7193 DEBUG Notifying about change for peer `6YNB' with address `tcp.0.192.168.1.15:12054' in state `S_INIT_ATS' timing out at Thu Feb 05 01:27:26 2015
Feb 05 01:27:21-443431 transport-7193 INFO Neighbour `6YNB' changed state to S_INIT_ATS with timeout Thu Feb 05 01:27:26 2015
Feb 05 01:27:21-443438 transport-7193 DEBUG Notifying about change for peer `6YNB' with address `<NULL>' in state `S_INIT_ATS' timing out at Thu Feb 05 01:27:26 2015
Feb 05 01:27:21-443445 transport-ats-7193 DEBUG Telling ATS to destroy session 0x2659a00 from peer 6YNB
Feb 05 01:27:21-443469 transport-7193 DEBUG Master task runs for neighbour `6YNB' in state S_INIT_ATS with timeout in 4999 ms
Feb 05 01:27:21-443518 transport-7193 DEBUG ATS suggests disconnect from peer `6YNB' with BW 0/0
Feb 05 01:27:21-443552 transport-7193 INFO Disconnecting from peer 6YNB in state S_INIT_ATS
Feb 05 01:27:21-443582 transport-7193 DEBUG Telling ATS we no longer care for an address for `6YNB'
Feb 05 01:27:21-462926 transport-7193 DEBUG Notifying ATS about peer `6YNB''s new inbound address `tcp.0.[::1]:38583' session 0x26668f0 in network LOOPBACK
Feb 05 01:27:21-462978 transport-7193 DEBUG Notifying ATS about peer `6YNB''s new inbound address `tcp.0.192.168.1.15:51443' session 0x2666a30 in network LAN
Feb 05 01:27:21-469201 transport-7193 DEBUG Notifying ATS about peer `6YNB''s new inbound address `tcp.0.192.168.1.15:48316' session 0x2666f50 in network LAN
Feb 05 01:27:21-475272 transport-7193 DEBUG Notifying ATS about peer `6YNB''s new inbound address `tcp.0.127.0.0.1:41608' session 0x2668650 in network LOOPBACK
Feb 05 01:27:21-487558 transport-7193 DEBUG Requesting ATS to suggest address for `6YNB'
Feb 05 01:27:21-487577 transport-7193 INFO Neighbour `6YNB' changed state to S_SYN_RECV_ATS with timeout Thu Feb 05 01:27:26 2015
Feb 05 01:27:21-487585 transport-7193 DEBUG Notifying about change for peer `6YNB' with address `<NULL>' in state `S_SYN_RECV_ATS' timing out at Thu Feb 05 01:27:26 2015
Feb 05 01:27:26-487749 transport-7193 DEBUG Master task runs for neighbour `6YNB' in state S_SYN_RECV_ATS with timeout in 0 ms
Feb 05 01:27:26-487792 transport-7193 INFO Connection to `6YNB' timed out waiting ATS to provide address to use for SYN_ACK
TagsNo tags attached.

Activities

Christian Grothoff

2015-02-05 01:44

manager  

test_transport_api_restart_1peer.log (54,916 bytes)

Christian Grothoff

2015-02-09 00:02

manager   ~0008847

Should be fixed now, at least for proportional solver. But should be confirmed.

Christian Grothoff

2015-02-09 17:08

manager   ~0008849

Seems to be good after the last fix to the stability logic.

Issue History

Date Modified Username Field Change
2015-02-05 01:44 Christian Grothoff New Issue
2015-02-05 01:44 Christian Grothoff Status new => assigned
2015-02-05 01:44 Christian Grothoff Assigned To => Matthias Wachs
2015-02-05 01:44 Christian Grothoff File Added: test_transport_api_restart_1peer.log
2015-02-09 00:02 Christian Grothoff Note Added: 0008847
2015-02-09 00:02 Christian Grothoff Assigned To Matthias Wachs => Christian Grothoff
2015-02-09 00:19 Christian Grothoff Target Version => 0.11.0pre66
2015-02-09 17:08 Christian Grothoff Note Added: 0008849
2015-02-09 17:08 Christian Grothoff Status assigned => resolved
2015-02-09 17:08 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-02-09 17:08 Christian Grothoff Resolution open => fixed
2018-06-07 00:25 Christian Grothoff Status resolved => closed